Jump to content
SpesoftPinballXConvert-It
surfdesign

PBX Recorder videos not playing in Pinball X

Recommended Posts

I just recorded a batch of videos (in both formats,MP4 and FFV, to check) using PBX Recorder for Visual Pinball. The videos went to the correct folders in Media/Visual Pinball and play fine on their own. I've installed LAV Filters and VLC Player. The problem is they no longer play in Pinball X. Ones that were downloaded by the Game Manager still work and I recorded one with Game Manager and it worked. The PBX Recorder is just so easy to use for all the tables (set and let it run) that I'm wondering what the problem could be?

Thanks for any help,

Share this post


Link to post
Share on other sites

I don't use PBX recorder, but I use Gamemanager to create all my videos. 

There is an option to create all missing videos too in gamemanager. Whats the benefit of using pbx recorder compared to gamemanager ? 

Share this post


Link to post
Share on other sites

Did you record against game description or name in pbx recorder? Is it all new videos or just some tables?

Please also attach copy of your pbx recorder log file, and your visual pinball xml. 

Share this post


Link to post
Share on other sites

I use pbxrecorder myselve instead of game manager. Not really sure its what i started with. I've never tried game managers recording but pbx recorder has options to tell it how long to wait before recording (which is handy if some tables load more slowly, and not sure how game manager's recording would handle this) and how many seconds the video must be. It also records everything at the same time although does not seem to record the dmd with me but i also don't have a dmd screen. Does game manager's recording record backglasses etc also at the same time ? PBX recorder recordings can also be stopped or paused

One thing you could look at is if your LAV codec output formats are setup like this but it would be weird if some recorded video's play and others not so i doubt this is the problem as they all use the same codec but you can verify (ignore red circle in screenshot, male sure all the checkboxes are the same with you)

image.png.ae8a6c597c520e73e1b0f724d6d44783.png

Share this post


Link to post
Share on other sites

So I ditched the PBX Recorder for the Game Manager capture tool. I've recorded both tables and backglass fine. When playing straight from the folder, the table videos play fine but the backglass videos gave me a "can't play 0XC1010103" error. I switched to VLC media player and they play fine from the folder but the backglass videos still won't play in Pinbal; X on my second (2) screen. The table videos play fine on my main (1) screen. When I start a table, the backglass and table work fine. My LAV filter setup looks just like that above. I had hardware acceleration checked but unchecked it. Could having both the LAV filter and VLC Player installed (with another version of LAV) be a problem?

 

Update - I added a few more tables via game manager. One one I used the video capture and the other I left the videos that were downloaded by the manager. The backglass downloaded by the manager played on the 2nd screen, the one I captured still didn't but is in the folder and playable via VLC.

Edited by surfdesign
update

Share this post


Link to post
Share on other sites

So the problem now is backglass videos captured by game manager don't work in the front end? (but you can open them ok in VLC)

VLC shouldn't be a problem, i have that installed too. I'd reinstall LAV codecs from Pinballx homepage and if that still doesn't work, post a screenshot of your LAV settings and attach a copy of pinballx.log file after recording new videos. Smells like a lav issue somewhere..

Share this post


Link to post
Share on other sites

Whelp, I gave up on the videos for the time being. I just took screen shots of the broken/missing ones. Not sure what is the problem but Google has NOT been my friend. Many hours spent and many codecs later, to no avail. It has something to do with Windows 10 Pro Media Player/Movies & TV that won't play the file. I guess that Pinball X uses that even when I change the default player to VLC that plays them just fine? Weirdest thing I've seen. 

Share this post


Link to post
Share on other sites

This is probably because the videos are recorded as 444 instead of 442. Its a common issue. This should not be an issue if recorded in the latest version of PinballX. You did not post any log files though so hard to know what is going on or what version you are using,

Share this post


Link to post
Share on other sites

I downloaded the latest version and tried to record with the game manager. The table video works, backglass still doesn't. Not sure how to record straight using PinballX. I've attached my log file and the two videos that were recorded. This is the backglass error I get:

 

image.png.a53b73a1119548d4e3ffda7da5aad008.png

 

Thanks for any help. 

Jeff

log.txt

Share this post


Link to post
Share on other sites

Im just asking for the log for the PinballX session when the videos were created via the game manager.

 

(For the log you posted no videos were created).

Share this post


Link to post
Share on other sites

Thanks. Its a bug/oversight on my part. Fixed in 4.09. Available in 10 minutes.

Cheers.

Tom.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...