Jump to content
SpesoftPinballXConvert-It
trislaver

[RESOLVED] Game Launch Issue

Recommended Posts

As a newbe I could really use some help getting an emulator setup in GameEx. I am using Mednafen and it works fine running .cue files or is using medgui, on a fresh built Win XP (off network)I added it to Emulators in GamEx and it shows all the game roms but  I'll click the game title, the next window opens, where I again see the game title and an option to add to favorites, but the game will not launch. I enabled .zip in the setup, and the Rom folder has both zipped and unzipped versions of the Roms.  I also tried setting the rom filter for .cue which is what I use to play the games outside of Gameex.

I am enclosing the .ini files, any assistance is greatly appreciated

Thanks in advance.

GameEx.ini tempemuimport.ini

Share this post


Link to post
Share on other sites

Hi trislaver,

You have to set up your command line properly. Now, this is the first time I have looked at Mednafen, so my experienece with it is limited to say the least...this should get the game running, but you may need to tweak things a bit. I tested PSX specifically:

  • For your command line parameter, use mednafen.exe "[ROMPATH]\[ROMFILE]"
  • Make sure your Working path leads to the folder that mednafen.exe resides in.
  • Make sure your ROM path leads to the folders the games reside in. If you have the games in separate folders, there is a setting in the Advanced Emulator Setup section called Scan Sub Folders that should be set to YES.
  • Set your Rom Filter to *.cue;*.ccd;*.toc;*.m3u
  • Also make sure you have the proper bios files if you attempt to run any games that need them. Those files belong in the firmware folder of Mednafen.
  • To go from Windowed to full screen, hit ALT+ENTER after the game had launched. There does not appear to be a command line setting to force this, although there may be a way using the mednafen.cfg file.

Hopefully this gets you started.

Documentation for mednafen itself is located at https://mednafen.github.io/documentation/.

  • Like 1

Share this post


Link to post
Share on other sites

Thank you for replying so quickly, I will try this when I get back and keep you posted...

Share this post


Link to post
Share on other sites

Went over all settings in gameex, I can see the PSX games listed but still can not launch them.

I am including screen shots and latest .ini

this is a real head scratcher, just don't see why the titles are grayed out when trying to launch. They play fine from medgui.

config1.bmp config2.bmp config3.bmp config4.bmp gameex_screen_game_grayed_out_in_list.bmp GameEx.ini

Share this post


Link to post
Share on other sites

Hey trislaver, I assume we are looking at emulator #9. Your command line is still incorrect.

You have it listed as notepad.exe. It needs to be mednafen.exe "[ROMPATH]\[ROMFILE]".

In the Advanced Emulator Setup for Emulator #9, you have Also Launch set to E:\Mpsx\mednafen-1.22.2-win32\mednafen.exe. Clear that parameter.

Also in the Advanced Emulator Setup for Emulator #9, you have Zip/7-Zip/GoodMerge/RAR set to Yes. This is fine if all of your games are zipped. If not, be sure to disable it.

 

I cannot see anything else to look at. Please make these changes and let us know if that gets things going.  :)

Share this post


Link to post
Share on other sites

Thanks RedDog, I was in emulator14, games are now launching but I get a command prompt saying to press any button THEN the game launches. I am attaching another screenshot. Any way you may know of to eliminate this step?  I am very grateful for all the help so far and so are my kids who are enjoying these games as much as I do, Thank you

cmd_line_popup.bmp

Share this post


Link to post
Share on other sites
7 minutes ago, trislaver said:

I was in emulator14... 2.25 MB · 0 downloads

OK, well, that would have been a helpful tidbit to know...at least we are making progress though...

Please repost your gameex.ini.

Share this post


Link to post
Share on other sites

Sorry about that...all working fine after pressing any key to close the cmd box...

Share this post


Link to post
Share on other sites

In the Advanced Emulator Setup, set Debug Mode to No for each emulator.

I believe that is the only change needed.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks RedDog,

All Problems are solved. Thanks for the great advice, my kids & I are enjoying these games immensely. 

Share this post


Link to post
Share on other sites

Cool. Glad to hear it. Have fun. :banana:

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...