Jump to content
SpesoftPinballXConvert-It
rtkiii

[RESOLVED] GameEx Arcade - Not showing Emulators

Recommended Posts

Hey guys,

 

Been awhile since I have had to modify my Arcade settings but I am trying to add "Fix it Felix" to my GameEx Arcade and I cannot seem to get emulators to display.  I can see MAME and some custom lists I made awhile back.  I tried adding an atari emulator as well just to see if it would display and it does not.

 

I am sure I tweaked something ages ago but i cannot remember.  I verified emulator is enabled and did not see anything in adv emulator settings but I could have spaced over it.

 

suggestions?

 

Thanks,

Rich

Share this post


Link to post
Share on other sites

thanks Tom!

Share this post


Link to post
Share on other sites

friendly bump if anyone has an idea

Share this post


Link to post
Share on other sites

I'd like to point out that you are running GameEx Arcade 15.10 and I am using the latest version of 16.07. Some things may have changed between yours and mine. I am not saying that you have to upgrade, but it makes this more challenging. I would not ask you to upgrade except as a last resort or unless a reload is suggested.

The first thing I see in the log.txt is that each emulator other than the integrated Mame emulator has an error stating that the mapfile does not exist. You will find these values in the Advanced Emulator Setup sections for each of the emulators. In GameEx Arcade 16.07, there are no mapfiles included in the install by default; not sure on 15.10. I suggest you recheck the mapfile paths on your install to see if the paths and filenames are 100% correct.

I do not see anything wrong with your emulator configuration paths or command line unless the paths where your files actually reside have changed.

 

One thing I suggest is to change your command line in the Emulator Setup for each of your emulators to the following (you have the same flags enabled on the Integrated Mame, so I assume you would want to be consistent):

mame.exe [ROM] -rompath "[ROMPATH]" -nowindow -joy -skip_gameinfo

 

You also mentioned trying to add an Atari emulator, but there is no Atari emulator in your config. Where should I see it? Emulators 1 through 5 are there and they are all Mame driven emulators.

  • Like 2

Share this post


Link to post
Share on other sites

Thanks for the info.  I have added a map file but alas no changes.  I might have said Atari as an example but I am really trying to add :"Fix it Felix" - which I felt I followed the instructions correctly as I believe those instructions said to add as an emulator

 

1.PNG

2.PNG

Share this post


Link to post
Share on other sites

one thing I have noticed is I have 4 other Mame Lists setup for various lists I want and one is called Alli's List.  If I look at the config that says is emulator 1...yet I do not see it listed in GameEx Arcade Setup screen...like you see above.  Alli's List seems to work ok and gets artwoirk.  But I have a top ten list that only pulls in the list...and I have been trying to figure out how in the world I got Alli's List created ok ...I did this last year  :) sometime.

 

I wonder if the GUI in the setup instructions is not showing the correct Emulators?

Share this post


Link to post
Share on other sites

I see the other emulators I added...they are all mame so I think I needed to edit the config manually for this work...I rthink I need to make FIF Emulator 6...i have some other things i need to tweak before i know for sure

Share this post


Link to post
Share on other sites

hmmm...made my changes and moved FIF to Emulator 6 slot and slot 10 in GameEx Setup but it never write to the gameex.ini file...hmmm

Share this post


Link to post
Share on other sites

Just a stab in the dark. Have you checked the admin rights or permissions?

Share this post


Link to post
Share on other sites

This is an admin account but do you mean running in Admin mode?  I can definitely double check that.

Share this post


Link to post
Share on other sites

For Fix-it Felix, the configuration you have in GameEx Arcade is fine. I tested the same setup with a the executable for Notepad++ and was able to successfully launch it and exit back to GameEx Arcade 16.10.

I did come across was a version of Fix it Felix on the net (I can't say where), but I could not get it to run on my box. It kept erroring out staying that it could not find another file. Can you confirm if the game runs on it's own on your setup? You might also try testing with a different executable (like notepad or something) just to see if it launches.

At this point, I am assuming either your Fix It Felix isn't actually working or something is 'broken' in GameEx Arcade and you may want to reinstall with 16.10.

Share this post


Link to post
Share on other sites

As far as the Mame emulators you have set up in the Emulator Setup area, I don't see any problem with the setup unless the path to the mame executable or roms are incorrect. These are the only two places in the Emulator Setup area I believe can cause the emulator to not show up properly in the list. If your paths are correct, you can try clearing the cache files by deleting any file with the .dbcache extension in the GameEx Arcade Editions\DATA Folder. They will automatically be recreated when you next run GameEx Arcade.

If that doesn't do it, I can only suggest reinstalling GameEx Arcade with 16.10.

Share this post


Link to post
Share on other sites

Hi Rich - I have this working in GameEx Arcade Edition. Following the exerpt from my gameex.ini file:

[Emulator_3]
Enabled=True
STARTPAGENAME=Fix It Felix Jr.
TITLETEXT=Fix It Felix Jr.
StartPageLogo=fifj
WorkingPath=J:\ROMS\Fix-It Felix Jr
RomPath=J:\ROMS\Fix-It Felix Jr
ROMFilter=*.lnk
(I right-clicked on fifj.exe and created a shortcut named Fix-It Felix Jr - this was to fix the name in the logo display.)
Command=fifj.exe
SnapPath=J:\Assets\Fix-It Felix Jr\Snap
LogoPath=J:\Assets\Fix-It Felix Jr
VideoSnapPath=J:\Assets\Fix-It Felix Jr\ThemeVideos
VideoThemePath=J:\Assets\Fix-It Felix Jr\ThemeVideos
DefaultVideoThemePath=J:\Assets\Fix-It Felix Jr\ThemeVideos
TitlePath=
DATABASE=
MapKeys=True
lastgame=
UseDbName=True

Give it a try. I have a few kinks to try to work out in how it displays in AE for the logo in the Wheel. (right now only displays text, not the logo file). Also need to work out how to get it to work properly with my X-Arcade Tankstick.  The wrapper is not friendly to it at all, but I will figure it out. 

EDIT: Got the settings to work with the Tankstick, so now to the AE flourishes. Reading the wrapper "readme.txt" file is fundamental. Easier than expected.

  • Like 1

Share this post


Link to post
Share on other sites
On 12/24/2019 at 7:46 AM, RedDog said:

For Fix-it Felix, the configuration you have in GameEx Arcade is fine. I tested the same setup with a the executable for Notepad++ and was able to successfully launch it and exit back to GameEx Arcade 16.10.

I did come across was a version of Fix it Felix on the net (I can't say where), but I could not get it to run on my box. It kept erroring out staying that it could not find another file. Can you confirm if the game runs on it's own on your setup? You might also try testing with a different executable (like notepad or something) just to see if it launches.

At this point, I am assuming either your Fix It Felix isn't actually working or something is 'broken' in GameEx Arcade and you may want to reinstall with 16.10.

I verified my FIF works fine outside of GameEx

Share this post


Link to post
Share on other sites

Ok with Draco's info I was able to get the FixitFelix to show in the game list but when I go into it it says no game found.  I am thinking I need to make a game list for it and it should be good.

 

 

I'll let you know...i am using 16.10, fyi

Share this post


Link to post
Share on other sites

Very odd. I didn't have to create a game list to get it working. Can you attach your gameex.ini and log.txt after making the changes? Thanks.

Share this post


Link to post
Share on other sites

or change the rom filter like you mentioned.  Changhed to .,exe and whala!!!!!  game plays.  Now to work on the graphics like you mentioed.  Thanks gents!

Share this post


Link to post
Share on other sites

You're welcome! Glad you've got it sorted! 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...