Jump to content
SpesoftPinballXConvert-It
Tom Speirs

PinballX 3.95 full screen exclusive mode

Recommended Posts

How are people getting on with this?

Im not getting the issues like before but ingame/pause doesn't seem to return to the table.

Share this post


Link to post
Share on other sites

Pause is now working for me in 3.97. 

Is this feature working for everyone else?

It makes the playfield super smooth when navigating.

Im not sure if I fixed the issues or its a result of 1909 or newer drivers.

Share this post


Link to post
Share on other sites

I will try tom later today. I used this feature, but turned it off after It didn't work anymore and you mentioned it was hard to fix B)

 

Share this post


Link to post
Share on other sites

Hey Tom,

Just to be sure (because I don't really understand those settings).

You mean full screen exclusive mode within vpx, right ?

And pbx must run in Full screen mode, not windowed ?

 

Edit : tested to set vpx full screen exclusive mode, started game from pbx. Put it in pause, and went back to the game, but focus not on game(flipper buttons won't respond), but see the correct screens. Alt-tab brings me to the correct screen 

Share this post


Link to post
Share on other sites

I gave 3.95 a quick go yesterday in fullscreen exclusive, it was very smooth in navigation - but unfortunately it didn't like having the media player display over the top of the backglass in attract mode (https://www.gameex.info/forums/topic/22325-plugin-pinballx-media-player/), which make sense because it's exclusive(!), but i guess it proves it was working. For me i'll be using fullscreen windowed but i'm sure it'll be great for others, thanks for continued updates Tom.

 

Share this post


Link to post
Share on other sites
1 hour ago, Mike_da_Spike said:

Hey Tom,

Just to be sure (because I don't really understand those settings).

You mean full screen exclusive mode within vpx, right ?

And pbx must run in Full screen mode, not windowed ?

 

Edit : tested to set vpx full screen exclusive mode, started game from pbx. Put it in pause, and went back to the game, but focus not on game(flipper buttons won't respond), but see the correct screens. Alt-tab brings me to the correct screen 

No, this is only purely to do with PBX and always was. It is referring to fullscreen windowed (false for exclusive).

Share this post


Link to post
Share on other sites
4 minutes ago, Tom Speirs said:

No, this is only purely to do with PBX and always was. It is referring to fullscreen windowed (false for exclusive).

Ah ok. 

So, if full screen windowed is set to no, is that exlusive or must it set to yes ? (Little bit confusion for me)

Share this post


Link to post
Share on other sites

Don't know what you did Tom, but just tried v3.97 and whatever you did to fix the pause issue also means i can now have the media player in attract mode on top of the backglass with fullscreen windowed set to No (previously pinballx minimized itself)

Is there a definitive way to prove if pinballx is running exclusive rather than just fullscreen?

Share this post


Link to post
Share on other sites

Lol. I was always running in full screen exclusive mode. Never discovered issues with it

Share this post


Link to post
Share on other sites

Confirmed v3.98 is back to exclusive fullscreen for me (and like v3.95 not compatible with media player plugin with visible player, not a problem though as i can just to it pbx back to fullscreen windowed [or set plugin to non visible])

Share this post


Link to post
Share on other sites
25 minutes ago, scutters said:

Confirmed v3.98 is back to exclusive fullscreen for me (and like v3.95 not compatible with media player plugin with visible player, not a problem though as i can just to it pbx back to fullscreen windowed [or set plugin to non visible])

It should still work if it is not on the primary display as far as I can think. So perhaps try and bring it to the front/focus. It could be when the display is initialized its losing focus.

Share this post


Link to post
Share on other sites
27 minutes ago, Tom Speirs said:

It should still work if it is not on the primary display as far as I can think. So perhaps try and bring it to the front/focus. It could be when the display is initialized its losing focus.

Yeah, it's a little bit strange as it's only a small window on backglass, but causes pinballx to minimize when shown. Might just be a windows media player 'feature' with exclusive fullscreen apps.

Share this post


Link to post
Share on other sites

I am just going to disable it again. It seems it causes videos to stutter and probably causes other issues.

Windowed runs pretty fast these days anyway.

Share this post


Link to post
Share on other sites

Fair enough, i'm not sure if navigation was any smoother or not for me with it enabled. I might just have perceived a placebo effect initially, but i certainly didn't notice the difference when i went to 3.97 from 3.95 and assumed it was still running exclusive anyway.

Share this post


Link to post
Share on other sites

hmm. I cant think what has changed. Its not the full screen exclusive because that has been disabled again and plugins initialize before that anyway. Rest assured I am looking into it though. Thank you for letting me know.

Share this post


Link to post
Share on other sites

Not sure if it helps, but my plugin still works. Tested all version from 3.95 and up (to get full exclusive mode) but Dof still works for me

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...