Jump to content
SpesoftPinballXConvert-It
jdsabin1

FX3 tables - Using Different Parameters

Recommended Posts

@Mike_da_Spike you probably forgot to set REPOSITIONWINDOW to 1 by default its set at 0 which means it sets the position back to the center of the screen you have to set to 1 or it won't work. I will see if i can add another button for joystick.

  • Thanks 1

Share this post


Link to post
Share on other sites

RTFM Mike  RTFM ....

Sorry ! I'm a real IT prof. Never read the manual.

Sorry ! :cheers:

Share this post


Link to post
Share on other sites
6 hours ago, Mike_da_Spike said:

RTFM Mike  RTFM ....

Sorry ! I'm a real IT prof. Never read the manual.

Sorry ! :cheers:

No problem, btw @Mike_da_Spike try this version PinballFX3Launcher.zip  now, replace exe, run it once and check ini file, it will have added a LAUNCHBUTTON2 entry which you can change. Default is joystick button 1 which equals B button on a XBOX 360 joypad to also be used as a the launch button. Just an alternate (extra) button for LAUNCHBUTTON

Share this post


Link to post
Share on other sites

just released the new v4.0 version and sources contains all the latest changes that have been added the last few days.

https://github.com/joyrider3774/PinballX_Launcher_app/releases/tag/4.0

- Added Alternate Keyboard and Joypad launch key / button (LAUNCHKEY2 and LAUNCHBUTTON2 ini settings)
- Added window dragging and startup position support (REPOSITIONWINDOW, POSLEFT, POSTOP ini settings)

documentation about the new settings has been updated as well

https://github.com/joyrider3774/PinballX_Launcher_app

  • Like 1

Share this post


Link to post
Share on other sites

I need your help, since I follow the steps but it is clear that something I am missing or doing wrong.
Configure keyboard and controls, select two players or three players pulse and do not start pinball FX3 with any table, leave and as if nothing. I enclose ini and some screenshots if they can help me

setting PinballX.PNG

Sin título.png

PinballFX3Launcher.ini PinballX.ini

Share this post


Link to post
Share on other sites

Do you use steam or a "standalone" version of Pinball FX3?
If you have a "standallone" version, change the PinballFX3Launcher.ini :

PATH=C:\<PATH TO FX3 exe>\Pinball FX3.exe
and change the follwoing to 1 
DONTREADSTEAMPATHREG=1


This will avoid that the steam path is reading from registry (I highly recommend to use steam and install Steam)

(also remove the -offline, this will avoid you to have check the leader boards etc.)

 

Share this post


Link to post
Share on other sites
1 hour ago, Mike_da_Spike said:

Do you use steam or a "standalone" version of Pinball FX3?
If you have a "standallone" version, change the PinballFX3Launcher.ini :

PATH=C:\<PATH TO FX3 exe>\Pinball FX3.exe
and change the follwoing to 1 
DONTREADSTEAMPATHREG=1


This will avoid that the steam path is reading from registry (I highly recommend to use steam and install Steam)

(also remove the -offline, this will avoid you to have check the leader boards etc.)

 

I get to load pinball FX3 but I get 1 Player and select table
I also have an offline position because this way since PinballX does not make me have to touch any button or keyboard, leave the table directly, but with this it ignores

my PFX3 version is standra but cabinet mode activated

PinballFX3Launcher.ini

Share this post


Link to post
Share on other sites
1 hour ago, susoarkangel said:

I get to load pinball FX3 but I get 1 Player and select table
I also have an offline position because this way since PinballX does not make me have to touch any button or keyboard, leave the table directly, but with this it ignores

my PFX3 version is standra but cabinet mode activated

PinballFX3Launcher.ini 1.44 kB · 0 downloads

Change the following line

STARTPARAMS=--table_[TABLEFILE] -offline

To

STARTPARAMS=-applaunch 442120

The "table_[TABLEFILE]" is a passthrough from pbx (and tablefile will be the tablename you selected)

Share this post


Link to post
Share on other sites
9 hours ago, Mike_da_Spike said:

Change the following line

STARTPARAMS=--table_[TABLEFILE] -offline

To

STARTPARAMS=-applaunch 442120

The "table_[TABLEFILE]" is a passthrough from pbx (and tablefile will be the tablename you selected)

With this last one, I worked a lot thanks for your help

Share this post


Link to post
Share on other sites

When I select 2 or more players, I get a screen with a message

- You cannot access the online functions at this time, maybe due ...... -
Retry    Cancel


There is a way to skip these messages

Share this post


Link to post
Share on other sites

Why are you not able to get online ? Are you able to launch within fx3 a multiplayer game ?

Share this post


Link to post
Share on other sites
13 minutes ago, Mike_da_Spike said:

Why are you not able to get online ? Are you able to launch within fx3 a multiplayer game ?

I don't have an internet connection in the pinball

Share this post


Link to post
Share on other sites

Add -offline parameter at the end of start parameters maybe it helps. That message has nothing todo with multiplayer or the launcher.

Share this post


Link to post
Share on other sites
10 minutes ago, joyrider3774 said:

Add -offline parameter at the end of start parameters maybe it helps. That message has nothing todo with multiplayer or the launcher.

where and should i put it ..
I'm trying to learn all this but the truth is complicated

Share this post


Link to post
Share on other sites
1 hour ago, susoarkangel said:
where and should i put it ..
I'm trying to learn all this but the truth is complicated

It is all easy. In setting.exe put it as paramater. See the next screenshot

 

Share this post


Link to post
Share on other sites

Not sure setting it as parameter in pinball x settings app wil work the laucher only takes 1st parameter but hae not tried. Better to do it in the pinball fx 3 launchers ini file at the end of startparams if i remember correctly. Am not at home to verify atm

@susoarkangel In pinball FX3.ini change

STARTPARAMS=-applaunch 442120 

to

STARTPARAMS=-applaunch 442120 -offline

 

Share this post


Link to post
Share on other sites
On 11/9/2019 at 9:03 PM, joyrider3774 said:

Not sure setting it as parameter in pinball x settings app wil work the laucher only takes 1st parameter but hae not tried. Better to do it in the pinball fx 3 launchers ini file at the end of startparams if i remember correctly. Am not at home to verify atm

@susoarkangel In pinball FX3.ini change

STARTPARAMS=-applaunch 442120 

to

STARTPARAMS=-applaunch 442120 -offline

 

After restarting and retesting, I don't know what happened but the script for pinball takes almost 1 minute to appear on the screen

Share this post


Link to post
Share on other sites

Just happened across this utility tonight....... WOW did not know it existed, you sir have opened up a whole new world to me using table launched from PinballX

Installed like a dream using instructions on GitHub

 

THANKS !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...