Jump to content
SpesoftPinballXConvert-It
pixelcade

[ATTN TOM] Launch Before and Launch After Works with Game Ex Evolution but not with Game Ex Arcade Edition

Recommended Posts

I'm in the process of integrating some LED marquee external hardware http://ledpixelart.com/pixelcade with GameEx and for this hardware to work, I'm utilizing the "Launch Before" and "Launch After"  features to launch an external batch file each time a game launches and exits. It's working just fine with GameEx Evolution but does not work when using GameEx Arcade Edition. On GameEx Arcade Edition, the batch files on game launch or game exit are not being triggered. The attached screen shots show the setup wizard configs for both GameEx Evolution (working fine) and Game Ex Arcade Edition (not working). Any advice would be greatly appreciated, thanks!

 

vertical-marquees450.gif

 

launch before gameex arcade edition.png

launch before gameex evolution works fine.png

Share this post


Link to post
Share on other sites

Please attach copies (no copy & paste) of your gameex.ini and log.txt files along with copies of your batch files for review. Thanks.

Share this post


Link to post
Share on other sites

thanks so much for the quick response! Attached are the files for Game Ex Arcade Edition where it's not working. If you also need these files for Game Ex Evolution where things are working, just let me know and I'll attach those too. On the batch files, mame.bat is the batch file called in "Launch Before" and default.bat is the batch file for "Launch After", both of these batch files will call the main batch file: pixelcade.bat. Thanks again!

 

GameEx.ini log.txt mame.bat pixelcade.bat default.bat

Share this post


Link to post
Share on other sites

Have you tried changing C:\MAX 2.10\Pixelcade\mame.bat mame "[ROMPATH]\[ROMFILE]" to read C:\MAX 2.10\Pixelcade\mame.bat mame "[ROMNAME]" to match the argument in GameEx Evo?

Share this post


Link to post
Share on other sites

BTW, are you the Pixelcade author?  In the mean time, I am going to elevate this to Tom's attention. My guess is that whatever he may need to do or suggest to fix the issue likely impacts normal GameEx as well.

Very cool product!

Share this post


Link to post
Share on other sites

thanks so much Draco, really appreciate your fast response! Yes I'm the creator of the Pixelcade LED marquee and thanks for your kind words. It's a new product that was just released 3 weeks ago and am in early testing with a handful of arcade builders now. One of them is using Game Ex Arcade Edition so it would be great if we could get it working, it currently works with HyperSpin, Maximus Arcade, and RetroPie. I'm pretty certain the issue is that the .bats are not being called within Game Ex Arcade Edition for some reason. Even if the rom path variable was wrong, the .bats would still be run and I can tell they're not running as I have a log file on my end. I attached here the log files for Game Ex Evolution where the integration and .bat files are working just fine for launch before and launch after. And also just for reference, here's the instructions how to integrate with Game Ex Evolution http://ledpixelart.com/pixelcade/ Thanks again! Al

[GAMEEX_EVOLUTION_SETTINGS].xml [SETUPWIZARD].log [GAMEEX_EVOLUTION].log

Share this post


Link to post
Share on other sites

Would also be good to get this to work with the integrated MAME, DAPHNE, Model 2, Model 3, and AAE support for GameEx/GameEx Arcade and other integrations (Steam, Uplay, and Origin).

Share this post


Link to post
Share on other sites

For sure , mame and Daphne are there now . For the others , as long as the rompath variable passes the game name , it’s something I can easily add into the next release 

Share this post


Link to post
Share on other sites

Hi,

Please post \data\runitgame.bat

If I recall the run before and run after are put in the bat file.

You may need to prefix the commands with start /wait

Also you need to put the path in quotes as it has a space in it. Pretty sure that is your issue. Try that first.

e.g:

"C:\MAX 2.10\Pixelcade\mame.bat" mame "[ROMPATH]\[ROMFILE]"

Share this post


Link to post
Share on other sites

thanks Tom, I tried with quotes first but no change. Also tried with start / wait in front too. So to eliminate something funny with my .bat, I just created a generic bat that just writes a file if it ran but no luck either. Probably something stupid on my end but out of ideas, let me know if you have any other ideas. Attached my generic test.bat file and runitgame.bat. Runitgame.bat does show my command in there but the test.bat doesn't actually run.

chcp 65001
C:
CD "C:\Emulation\Emulators\MAME"
start /wait "C:\test\test.bat"
mame64.exe 1941 -rompath "C:\Emulation\ROMs\MAME\Roms"

 

runitgame.bat test.bat

Share this post


Link to post
Share on other sites

thanks Tom, tried that on both test.bat and my normal .bat, still doesn't launch though

chcp 65001
C:
CD "C:\Emulation\Emulators\Jnes"
start "" "C:\MAX 2.10\Pixelcade\nes.bat" nes "C:\Emulation\ROMs\Nintendo NES\Roms\1942 (Japan, USA).zip" /wait
Jnes.exe "C:\Emulation\ROMs\Nintendo NES\Roms\1942 (Japan, USA).zip"
start "" "C:\MAX 2.10\Pixelcade\default.bat" nes /wait
 

runitgame.bat

Share this post


Link to post
Share on other sites

should be.

 

start /wait "" cmd.exe /c "C:\MAX 2.10\Pixelcade\nes.bat" nes "C:\Emulation\ROMs\Nintendo NES\Roms\1942 (Japan, USA).zip" 
Jnes.exe "C:\Emulation\ROMs\Nintendo NES\Roms\1942 (Japan, USA).zip"
start /wait "" cmd  /c "C:\MAX 2.10\Pixelcade\default.bat" nes

 

Working fine for me in my testing.

 

If its not working you probably need to set the path (CD) in your batch files.

Share this post


Link to post
Share on other sites

Actually scrap all that. Batch files just seem problematic as launch before and launch after.

I was succesfull converting the bat file to an exe using this.

https://www.majorgeeks.com/files/details/bat_to_exe_converter.html

It works fine as an exe no need for the start wait etc. You will still need to ensure the path is in quotes though

Share this post


Link to post
Share on other sites

thanks Tom, will try that later and post tomorrow. Note that adding in CD without start and wait, my .bat ran but the game didn't run. With start and wait, the game ran but my .bat didn't. Have to head out , will post results tomorrow, thanks for all your help.

Share this post


Link to post
Share on other sites

well no luck with the .bat to .exe converter but in my case, my bat is calling other bats so it's not so straightforward. But did play around some more and this seems to do the trick. Note I don't need the /WAIT in this case as the game can launch while the LED marquee is writing in parallel but adding /WAIT also works too. I'll need to test some more but so far it's working. Actually this way is better for my use case as my customers may need to add their own tweaks in the launch before and launch after so more practical to do that in .bat where they can easily edit vs. exe's. I'll test some more and report back but initial results look good.

Separate question, would you by chance have a variable like [ROMPATH] or [ROMFILE] or [ROM] that gives the platform/console name?

chcp 65001
C:
CD "C:\Emulation\Emulators\Jnes"
start "" /D "C:\MAX 2.10\Pixelcade" "nes.bat" "nes" "C:\Emulation\ROMs\Nintendo NES\Roms\1942 (Japan, USA).zip"
Jnes.exe "C:\Emulation\ROMs\Nintendo NES\Roms\1942 (Japan, USA).zip"
start "" /D "C:\test" test.bat

screen-grab-start.jpg

Share this post


Link to post
Share on other sites

Hey, I checked out your site. You know a plugin would work much better for this. If you wanted to send some kit Id be happy to code one for you as a fun little project. I need to get more up to speed with Evo anyway too.

Share this post


Link to post
Share on other sites
16 hours ago, Tom Speirs said:

Hey, I checked out your site. You know a plugin would work much better for this. If you wanted to send some kit Id be happy to code one for you as a fun little project. I need to get more up to speed with Evo anyway too.

Funny you mentioned that as I was going to suggest a plugin or an integration (similar to what was done with LED Blinky). :P

Share this post


Link to post
Share on other sites

Hey Tom, that's a great idea! let's go for it, really appreciate that. Go ahead and pick out a kit here  http://creativeartsandtechnology.com/product/pixelled-art-makers-kit-arcade/  (if you can find a size that fits your cabinet, even better). I'll send you a private message for your mailing address. Note that I'm out of the country at the moment and back in town 6/24 and will ship to you then.

Share this post


Link to post
Share on other sites

Also, here's the documentation for the command line to write to the LED marquee http://ledpixelart.com/pixelcade-cli/. This works fine for on game start and on game end but it's not good for front end scrolling (when scrolling through the games in the Evo wheel) because it takes ~2 seconds to write to the LED marquee. But I'm working on a new API that will stream instantly. That should be ready close to the time you get the kit, will send details there later once ready.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...