Jump to content
SpesoftPinballXConvert-It
bduncan

Issue with PinballX and PBFX3 after upgrading to Win10

Recommended Posts

Hello,

Was previously running Windows 8.1 and the most current version of PinballX in my cabinet.  Use primarily PBFX2 and PBFX3 at the moment.
PBFX2 loaded and exited without issue very quickly.  PBFX3 would take a long time to load. (compared to PBFX2) You would select a PBFX3 table and launch it, and the screens would blink and eventually when the main display would regain focus I would see the PBFX3 loading screen for whatever table I had chosen and then shortly after the table would come up and I would play.

PBFX3 was obviously the hold up but it all worked pretty seamlessly.  

Today I updated this machine to Windows 10,  I am back to PBFX2 working without issue very quickly.  One thing I have noticed is that PBFX3 loads way quicker now under Win10, so the issue I am having is that when I launch a PBFX3 table from PinballX, the screens flicker a few times and within 5 seconds the PBFX3 specific backglass is up, and by 7 seconds the PBFX3 table is already up and loaded, but my main playscreen stays black for another 7 or so seconds before it finally pops up (while the DMD is running and the backglass is up) with the display halfway into the intro of the selected PBFX3 tables.  Does not look very nice now.

I am really happy that my load times for PBFX3 tables have increased so much when moving to Windows 10, but why is PinballX so slow to the draw with PBFX 3?

I looked in my log.txt and it seems to take PinballX a pretty long time to see that PBFX is running when I know for a fact that after launch I see the DMD/backglass for the game load after like 5 seconds, so is running by then.  I see it take anywhere from 16 seconds to 30.

I have played around with the Wait for settings for PBFX3 in the GUI settings, the minimum I can select in the GUI is 11 seconds, I have also tried setting below that in the .ini manually and that does not make any difference. 

I am wondering if PinballX ignores anything less then 11, and defaults to 11.  I need to be able to go lower if that is the case, because my system is really fast now on Win10.  I think PBFX3 tables might be loading as quick or quicker than PBFX2, which I never had before under Windows 8.1

Anyone know how I can fix this?

I have attached my files.

Thanks!

[SETTINGS].log log.txt PinballX.ini

Share this post


Link to post
Share on other sites

Do you have an animated gif as the loading screen? That seems to cause a long delay launching anything. Perhaps remove it?

Share this post


Link to post
Share on other sites

No, no loading screens at all. in \media\loading images I just have loading.png.old so it is disabled..

 

 

Share this post


Link to post
Share on other sites

Okay, Ill look into it. If its not something obvious it may be a while.

Are you using cabinet mode?

Share this post


Link to post
Share on other sites

Any update on this Tom?  Is this something you can account for in PinballX moving forward at some point?

One of the things I did determine is that WaitFor= directive under PinballFX3 does seem to be ignored for any value below 11.

I can set it from -1 to 11 and have the same results. (manually with a text editor)

The results look the same also for anything above 11, but what I noticed if you increase above 11, it takes even longer after PBFX3 is loaded until it will catch the ESC and exit back to PinballX. Up until then when you hit ESC PBFX3 catches it and pauses the game.

Based on how quickly my PBFX3 loads, I am guessing if I could set that directive and have it use it, to like 4 or 5 seconds I would be good.

Thanks

 

Share this post


Link to post
Share on other sites

Just checking to see if you had a chance to check on this, is it possible to make it so you can set a delay lower than 11 on that waitfor= directive?

 

Thanks

 

Share this post


Link to post
Share on other sites

Sorry, not a had a chance yet. Don't even have a working pfx 3 setup on the cab right now. You said you are using cabinet mode with fx3 though. The wait for setting should have no effect with cabinet mode.

Other than that loading gifs can cause issues.

Share this post


Link to post
Share on other sites

I know you have LaunchBeforeWaitForExit=False, but what's in LaunchBeforeExecutable=fx3.savedel.bat ?

Same result if you disable the LaunchBefore for FX3?

Share this post


Link to post
Share on other sites

I have a 2 screen setup with a real dmd. My fx3 is starting also in a few seconds. 

My launch before is launching dmdext to have the dmd mirrored.

But I don't have the issue that my screen flickers. I rotate the screen 270 degrees in pbx.

As @scutters mentioned. Whats the content of fx3.savedel.bat ?

Share this post


Link to post
Share on other sites
12 hours ago, scutters said:

I know you have LaunchBeforeWaitForExit=False, but what's in LaunchBeforeExecutable=fx3.savedel.bat ?

Same result if you disable the LaunchBefore for FX3?

It is just a  script that DEL /F/Q/S the savegames for PBFX3.  When you exit PBFX3 without doing so gracefully it leaves behind a save game that the next time you launch it will ask if you want to resume.

 

So my batch file deletes those save games then has an exit directive.  Let me disable that, I don't recall now if I already ruled that out.. I probably did.

 

Yes, it seems to make no difference at all.  The Pinball FX 3 tables fully load and are available for 7 seconds while the play field screen stays black.  During that 7 seconds the playfield is black you can hear the intro in PBFX3 for whatever table is loaded and you can see the DMD going on my DMD screen and whatever background table screen there is on my 3rd screen.

 

So when you choose a Pinball FX3 table from within pinball X, how many seconds is it after that, that the table is up the intro is playing for the Table you chose?  For example Jaws, when he starts talking with his intro, it is around 5 seconds when I choose jaws in Pinball X, till he is saying the intro for the table.  That is why I thought that 11 is the minimum on the WaitFor= directive  since 5 + 7 is around 11 seconds.  If I increase the wait for directive to more than 11 it increases the time that the main playfield is black while the table is loaded.  Before I get to see the play field.

 

 

Share this post


Link to post
Share on other sites
5 hours ago, Tom Speirs said:

It might be a little bug. Please try the attached.

PinballXx64.zip 698.15 kB · 1 download

Thanks!

I first upgraded to 3.57. Then removed the loading screen.

Confirmed it is still happening, renamed the pinballx.exe to .old.exe then copied over your test exe.

Still doing the same thing.

I compared times with both exe's and they are the same.

When I launch Jaws PBFX3, the moment the game starts and the guy starts doing the voice intro the playfield screen is black for 8 seconds before it finally displays the playfield screen.  (But backsplash and DMD from the game are displaying fine during these 8 seconds)  It seems to be the same time between both the default 3.57 and your test exe.

I also tried changing the waitfor directive under PBFX3 from the default of 11 I had to 5 and -1 and neither seemed to make any difference.

 

 

Share this post


Link to post
Share on other sites

I think this is just normal behaviour with PinballX as it does its upmost to make launching games seamless and hide windows.

Share this post


Link to post
Share on other sites

I will check when I am  at the cab. But you don't see Fx3 splash screen loading at all ?. Just black and you have visual and the game is already there ?

Share this post


Link to post
Share on other sites
16 minutes ago, Mike_da_Spike said:

I will check when I am  at the cab. But you don't see Fx3 splash screen loading at all ?. Just black and you have visual and the game is already there ?

Correct, when I launch the Pinball Fx3 table, the playfield goes black (where it normally would list loading image) I hear the PBFX3 background music table loading sounds, then the DMD and backsplash comes up (playfield still black at this point) and the intro starts for whatever PBFX3 table it is, in this case Jaws the guy is doing his intro, and then 5 seconds later the play field comes on.  Windows 8.1 did not do this,  I don't remember now how Windows 8.1 worked, but I did not have this happening.

 

I assumed this had to do with the waitfor variable, because if I increase it past 11 I think it stays black longer.  That's why I figured it was a matter of just being able to set the waitfor variable lower than 11.  The gui config tool shows 11 as being the lowest value on PBFX3 for the waitfor.

 

Share this post


Link to post
Share on other sites

I'm not using the 64 bit version of PBX, but the 32bit (because of the plugins comparability), but I see direct after PBX is launching a FX3 table the FX3 splash screen . So no delay for FX3

But ... I have the almost the same behavior with Pinball Arcooda. I noticed that the main exe file is most of the time behind the black screen of PBX.
I see backglass and DMD and sound is loaded. With a small AHK file I fix this, but takes me arround 15 seconds to get into pinball Arcooda. 

Not sure if PBX is trying to move the exe file in front after the waitfor time out ?

 

Share this post


Link to post
Share on other sites

I think the blackscreen or a loading image has a purpose, it prevents seeing the desktop while launching a systems applications / table. The reason the backglass is faster visible is probably because of the hide backglass option in game manager and the system boots faster then the time the black screen / loading image is displayed. While i can create a similar situation as described here, for example with other systems like bingo game room and i think pinball arcade using freecammod, i don't mind it and just wait a bit. I think trying to mess with these things could introduce other problems like people seeing the desktop when launching tables or trying to send keys or bringing the systems window to front (if pbx does that) or sending the blackscreen / loading screen to back (again showing the desktop then) too early etc. Although maybe being able to specify lower times for the wait for process might fix it in this case i've got them set to -1 mostly and just wait till i see the playfield. 

It could also be you never noticed this on another windows version because it loaded slower, i have heared people saying switching to windows 10 decreased load times or perhaps you also upgraded hardware

Share this post


Link to post
Share on other sites
17 hours ago, Mike_da_Spike said:

I'm not using the 64 bit version of PBX, but the 32bit (because of the plugins comparability), but I see direct after PBX is launching a FX3 table the FX3 splash screen . So no delay for FX3

But ... I have the almost the same behavior with Pinball Arcooda. I noticed that the main exe file is most of the time behind the black screen of PBX.
I see backglass and DMD and sound is loaded. With a small AHK file I fix this, but takes me arround 15 seconds to get into pinball Arcooda. 

Not sure if PBX is trying to move the exe file in front after the waitfor time out ?

 

 

I had to do something similar in the past with Pinball Arcade I believe.

So today I just setup a simple AHK script to close pinballx.exe, and I set that to launch before Pinball FX3.

When I launch the PBFX3 table, pinballX is terminated immediately then PBFX3 launches and the logo displays for PBFX3, and the the table starts., Now I see the PBFX3 logo and everything works.

I then switched the start before script from the above, back to my script that deletes any lingering FX3 save files. (disabling my terminate pinballx script)

It started working properly then after that..  When I launch a FX3 table from Pinball X the playfield now display PBFX3 launching, no black playfield screen for 8 seconds.

I tried rebooting my computer and it is still working properly now.

Makes 0 sense to me.

Thanks for all the help.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...