Jump to content
SpesoftPinballXConvert-It
MostlyDecaf

[RESOLVED] Pinball Arcade backglass turns black on table launch

Recommended Posts

I see a lot of posts from people with a similar problems, but none of the solutions fix things on my cab.   I have just rebuilt my hard drive from scratch, switching from hyperpin to pinballx, and I am trying to install The Pinball Arcade.  I do not have cabinet mode, nor am I running FreeCamMod.  I have installed Pinballx3.4, and the pinball arcade off steam.   Pinball Arcade runs fine on its own.  Every other emulator I have installed works fine as expected, including fx2 and fx3.  In the menu, the backglass is displayed.  When I launch a pinball arcade table, the backglass turns black.  I have looked at things using Alt-Tab, and the backglass image is still there, it is just black.  It does not matter how I set <hidebackglass></hidebackglass>  true or false.  Does anybody have a suggestion on what to try next?

 

PinballX.ini Pinball Arcade.xml log.txt

Share this post


Link to post
Share on other sites

I only have image files, no video files for these backglasses.   I am content to have still images.  I just find it very distracting to have a black backglass screen.  I would even be content to use a third party program to display back glass images for these tables, if I can figure out how.

Share this post


Link to post
Share on other sites

Althought you mentioned in the 1st post it does'nt matter how you set the backglass, in the xml file it is set to true

This must be set to false

<hidebackglass>false</hidebackglass> 

Share this post


Link to post
Share on other sites

I have tried it both

<hidebackglass>false</hidebackglass> 

and

<hidebackglass>True</hidebackglass> 

, because I was not sure whether HIDE means hide the menu version, or hide the emulator version with the menu version. 

Share this post


Link to post
Share on other sites

Update:  I tried true and false again, just to see differences in the logs.   Afterward, I decided to try to use this program I found called showbackglass.  I filled out the start before part of the setup, to experiment   I did something wrong, because the program never started.  The thing is, the back glass stayed up after the table launched.   I have no clue why that worked.   I am guessing it has something to do with timing, but I am not sure how to delay things, to fix it correctly.

Share this post


Link to post
Share on other sites
8 hours ago, MostlyDecaf said:

I have tried it both

<hidebackglass>false</hidebackglass> 

and

<hidebackglass>True</hidebackglass> 

, because I was not sure whether HIDE means hide the menu version, or hide the emulator version with the menu version. 

It will hide the front end option.

Same as the dmd part

If you want to leave your backglass from frontend in simulator, just uncheck the option "Hide backglass" in gamemanager.

Not understand your last post.

Is the backglass present, but not foccussed when you laun the program ? 

Is Pbx running as admin as well ?

 

Share this post


Link to post
Share on other sites

You can ignore that last post.  I had mistakenly left the play field in portrait mode.  This causes the back glass to work for pinball arcade, but screws up visual pinball9 and future pinball.  So it seems it is the rotate play field feature that is breaking the backglass.

Share this post


Link to post
Share on other sites

Resolved!

For future people facing this problem.   My playfield display was in landscape mode, so that I could run visual pinball 9 and future pinball.  To run pinball arcade, pinballx rotated the display to portrait.  For whatever reason, this  caused the backglass to turn black. 

Solution:   Start with the display in portrait mode.   Then use the program irotate.exe  (free, I just googled it) to change the playfield to landscape for visual pinball 9 and future pinball. 

Launch before command is:

iRotate.exe /1:rotate=0 /exit

Launch after command is:

iRotate.exe /1:rotate=90 /exit

where my playfield is display 1.

I entered this in pinballx setup for both vp9 and future pinball.  Now everything works. 

I attached my ini file, in case this helps someone else.

Thank you for your help. 

PinballX.ini

  • Like 1

Share this post


Link to post
Share on other sites

Nice, not a PBA user myself but glad you got it sorted!

One thing though, unless you're a fan of having a hidden notepad window you might want to turn off this setting in your startup;

[StartupProgram]
Enabled=True
WorkingPath=
Executable=notepad.exe

Share this post


Link to post
Share on other sites

I wondered about that.  I don't know where that came from.  It was present in all entries.  I assumed it was supposed to be there, so I left it.

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...