Jump to content
SpesoftPinballXConvert-It
Sign in to follow this  
arcadezz

Low Quality Backglass Videos during Attractmode

Recommended Posts

Hello, I have a 3 screen setup and during PinballX attractmode it seems to lower *only* the quality of the backglass videos I have captured. After I load the table it loads the .b2s version and its vibrant and clear for the backglass. At first I thought it was the video capture, so I tried opening the video for the backglass and dragging it to the backglass monitor and it looks vibrant(no issues). During attractmode both the DMD and playfield quality are fine.

Any ideas? Thanks for any help.

Share this post


Link to post
Share on other sites

When reporting an issue, it is best to attach copies (no copy & paste, please) of your pinballx.ini and log.txt files.

Share this post


Link to post
Share on other sites

As Draco1962 suggests please attach the ini and log files.

Check you have installed LAV filters  (follow link on https://www.pinballx.com/) and confirm format of backglass videos (mps or f4v etc), are they the same format  as the playfield videos, what tool created them, when you say lower quality do you mean less contrast / brightness or lower resolution, and what is the native resolution for the backglass?

Thanks

 

Share this post


Link to post
Share on other sites

A video capture of the issue may also be of help. Seeing exactly what you are describing.

Share this post


Link to post
Share on other sites

Hi All, I did not have Lava filters installed and installed them into C:\Program Files (x86)\LAV Filters\x86 - the same issue persists.

I have attached my log.txt, PinballX.ini and 2 pictures:

When I load the table in PinballX and the B2S takes over it looks perfect.

Thanks for any help!! I have been trying to figure this out for a long time......

 

PinballX_washed_out.JPG - this is a picture of PinballX loaded, when I cycle through all the tables backglass is washed out looking.

PinballX_Washed_out.thumb.jpg.81ea1b522a4fc1cf2c17a4e47fe6b027.jpg

Video Playing JPG - This is a picture of me just playing the FLV file and dragging it to the backglass monitor - it dispalys correctly in color representation.

1664892320_VideoPlaying.thumb.jpg.5299f91b84655d704badcaf1613e831e.jpg

Share this post


Link to post
Share on other sites

Try this;

NVIDIA Control Panel -> Video -> Adjust video color settings -> Select Backglass Display -> Select "With the NVIDIA settings" -> Advanced tab -> Dynamic Range "Full (0-255)" 

Share this post


Link to post
Share on other sites
23 hours ago, scutters said:

Try this;

NVIDIA Control Panel -> Video -> Adjust video color settings -> Select Backglass Display -> Select "With the NVIDIA settings" -> Advanced tab -> Dynamic Range "Full (0-255)" 

Hi, tried this and still no change :(, thanks for the suggestion.

I did notice I have K-Lite codec pack installed (which does have the LAV filters, assume thats not he issue)

Still stumped.

Share this post


Link to post
Share on other sites

I reccomend uninstalling klite and using just the LAV codecs recommended by the author.

Share this post


Link to post
Share on other sites
17 hours ago, scutters said:

Ok..

Next up, set LAV as shown in this post

https://www.gameex.info/forums/topic/20816-pinballx-267-black-screen-resolved/page/3/?tab=comments#comment-178455

Not sure on K-Lite impact (if any). What player is it that shows the video on backglass ok?

I setup LAV as per the screenshot and no change.

The video player it displays correctly is MPC-HC, its the video player that came with the K-Lite pack.

I also tried uninstalling per Draco1962's suggestion. I uninstalled the K-Lite pack, rebooted, installed only LAV, rebooted, configured per the screenshot and still same issue.

Do you know which video player PinballX uses for the videos? Maybe I can try running it on its own or there is settings for video scale up/down?

Share this post


Link to post
Share on other sites

I'm light on ideas now... hopefully someone with more knowledge of LAV/CODEC settings will chip in.

One other nvidia setting to check in nvidia control panel is what is showing for the backglass under Adjust Desktop Color Settings, Application controlled or Nvidia for how colour is set?, try toggling that along with Digital Color Format drop down values (if available)

If they make no difference my suggestion for a workaround would be to use backglass images instead of videos, i guess they won't have the issue - but'd depend if you're happy with that.

Out of interest is windows media player washed out too on backglass?

Share this post


Link to post
Share on other sites

Maybe stupid question, but are the videos played correctly with media player ? 

I had the a simular issue with my playfield.

This was caussed by my Nvidia driver that set a filter on the videos, but looks much brighter. 

Not sure how I fix this,  not think I played around with the nvidia settings. 

Share this post


Link to post
Share on other sites

Have you tried an .mp4 video instead of .flv? Also, do you have a mix of .mp4, .flv, .wmv, etc. ?

I have witnessed where others were able to remedy some video display issues by switching to .mp4 and/or changing all video media to the same format.

Share this post


Link to post
Share on other sites

I have it set to Nvidia controlled....everything appears correctly on the backglass (games, videos, pictures, etc) except when in PinballX.

Yes, the windows player displays correcly.

I have tried the .mp4 versions.....same issue.

Share this post


Link to post
Share on other sites

..and tried all videos same format?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...