Jump to content
SpesoftPinballXConvert-It
wrd1972

Backglass not loading, on "long load time" VP10 tables.

Recommended Posts

Okay I am still having the issue with some backglasses not loading for very large VP10 tables. For example, my latest Funhouse rev 2.0, is extremely large, and takes more than 3x time to load up, and be ready to play compared to nearly every other VP10 table. So when I launch FH through PinballX. The table loads and is playable, but the backglass never loads at all, just blank screen. The two hundred plus other tables on my cab have their backglasses load perfectly fine, through PBX. No issues at all. Its just my FH table I assume due to its long load time.

 

The backglass was indeed loading on my previous rev of FH, which was smaller. But the latest 2.0 version, is much larger, and now the backglass problem popped up again.

 

And as before, if I launch FH through the VP editor, the backglass loads every single time without fail. So for some reason, PinballX does not seem to like the very long load times, of this table. Can the devs please download FH from Vpinball.com, and try to replicate this issue. And if there is an issue, can it be looked at. Here is the link to the table:

https://vpinball.com/VPBdownloads/funhouse-williams-1990/

 

Thanks

 

Share this post


Link to post
Share on other sites

Please attach copies of your pinballx.ini and the log.txt file after running some of the tables. Also including a list of tables you are seeing affected would be very helpful.

Share this post


Link to post
Share on other sites

In the deep past, I've gotten around this issue by running PinballX concurrently with Task Manager. Why? Who knows? It's Windows. I'm not sure that this is still the workaround with recent versions of PinballX. Something to try.

Share this post


Link to post
Share on other sites

Draco,

Attaching the files. I only have 1 table out of 221, that have this issue. And that table is FH. Every other table in my collection has its backglass operate as normal. I really think its related in some way to the  very long load time of this one table. Its size is the only thing that makes it rteally different than other table. And the fact it does work through the editor.

 

Outthere:

I copy pasted the two file from the link below, and registered it. Now I have no backglasses at all, even through the editor:

https://drive.google.com/file/d/1RpQiokTC_yYw1nAxaAF9NCpTVro9BQ0Y/view

 

Carny,

Did not work

PinballX.ini

log.txt

Share this post


Link to post
Share on other sites

I will try it again.

 

I also just found that Data East Star Wars VP10 has the same issue. Backglass will not load if launched through PBX.

But will load every single time, through VP10 editor.

Share this post


Link to post
Share on other sites

Might be the larger tables are a tipping point for system bottleneck if you're running 4k.

Anything in event viewer or task manager performance to indicate issues / maxing out?

All i can suggest is trying different B2S files to see if same result otherwise.

Share this post


Link to post
Share on other sites

Okay I mentioned that the backglass was not loading for VP10 DE Star Wars. I changed the "DMD" vale in the DB2S properties, from "standard" to "hidden".  And now the backglass APPEARS through PBX. Also Blacksad has made a new DB2S for Funhouse, and it seems to be working now with PBX. But the DMD proprieties in the DB2S, shows "standard". So who knows? If I can find some other problematic backglasses, I will try the trick I saw above. But I have to assume there must be some small issue with PBX and some backglasses...considering all backglasses work perfectly through the editor.

Share this post


Link to post
Share on other sites

You may want to upgrade to v3.32 and try installing the 32-bit version. Per your log file:

PinballX - Version 3.28 x64

Perhaps that may work better?

Share this post


Link to post
Share on other sites
1 hour ago, wrd1972 said:

Okay did the upgrade. Problem remains.

Tom may need to take a closer look. Can you please attach new copies of your log.txt and pinballx.ini files in reply  Also note again what tables are affected at this time. Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×