Jump to content
SpesoftPinballXConvert-It
Sign in to follow this  
E36M3ZF

[RESOLVED] PinballX causes frame time issues

Recommended Posts

I just discovered this and i need to see if it's a known issue or how to fix.

After using PinballX to launch Visual Pinball X, i noticed that some tables had microstutters that there weren't there before. Like, subtle repeated frames ever 20 seconds or so. You may or may not notice this, it depends on how sensitive you are with this. But it's there, and here's the proof:

Untitled.png.b680e770031acda1c2f75225bb694907.png

The first half of the graph is two tables played in Visual Pinball X, without the PinballX frontend in the background. You can see that the lines are perfectly flat.

The other half is the same tables but this time i launched them via PinballX. You can see the lines are not the same, Every about 20 seconds i lose a frame, which looks like a noticeable stutter.

This is very bad since i need PinballX to run a pincab. Is this known? Can it be fixed?

Share this post


Link to post
Share on other sites

You will need to attach copies of your pinballx.ini and log.txt files so that the author can review.

It may also be beneficial to identify the tables as you are indicating some, but not all.

Thanks.

Share this post


Link to post
Share on other sites

Sorry for the late reply but i was troubleshhoting this to find the cause.

It doesn't matter which table i use, the behavior is the same with all of them.

However, i noticed that sometimes it doesn't do that and the tables run 100% smooth with or without PinballX. So that means there's must be something funny with my system or panels. Need to test more.

Share this post


Link to post
Share on other sites

Providing the pinballx.ini and log.txt files (especially when the issue is noted) may give some insight. 

Share this post


Link to post
Share on other sites

which program shows that frametime info ? i could test to see if i see the same, although my pinball cab system is not very performant

Share this post


Link to post
Share on other sites

Could be a host of stuff from AV/Defender to Nvidia settings to VPX settings. What's your system setup and vpx video options?

Have a google for VPX stutter but we'll need more info to be more helpful

Share this post


Link to post
Share on other sites

Thanks all for the replies. I appreciate it.

The program i use for measuring is Afterburner.

The issue is with the system. Maybe the way it detects the screens (i have two). Sometimes when i go from one screen to the other i get this behavior. If i re-do the change, it fixes itself. That's only when i want to end up to the second monitor. The first monitor is always smooth 100% of the time. In my later testings i saw this behavior with VPX, even without PinballX so it's not an issue with the later as i initially thought.

So all is well, thanks again for the replies.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×