Jump to content
SpesoftPinballXConvert-It
designone

[RESOLVED] VPX and b2s in Pinballx

Recommended Posts

Hi,

I had an existing setup that used only vp9 or vp8 

I have switched to using VPX tables. I am now unable to get pinballx to load the B2s files when I load a table. They load fine WITHOUT  Pinballx, the backglass goes on the 2nd screen and the dmd loads on tables that need it with no problem. When I load it in Pinballx (first off.. If I'm not mistaken the b2s files were used in Pinballx as the backglass in the front end) and that was great I would load the table and everything would work.

Now when I select and run a table, the table playfield works and when it is called for the dmd shows on the second screen but the b2s never loads. 

Can someone tell me how to fix this?

Is there something in my last setup that I had in the settings that I've done wrong this time.

Thank-you

 

[SETTINGS].log

PinballX.ini

Share this post


Link to post
Share on other sites

Can you attach your log.txt file? It tells us much more than the settings.log file does. Thanks.

Share this post


Link to post
Share on other sites

I believe your issue is shown here:

10:20:30.0 2019-02-10: PinballX - Version 3.28 x64

I believe that you will need to download PinballX and install the 32-bit version as B2S will not run with the 64-bit version.

Share this post


Link to post
Share on other sites

Thank-you

I hope you are correct Draco1962 I have the installer ready to install and it seems I have two options Pinballx lite (tablet version)or 64bit I am not seeing a 32bit option.

Can you tell me where to get the 32bit installer.

Thank-you Outhere I will change that now and see if that helps

Share this post


Link to post
Share on other sites

Just don't check the install 64bit checkbox in the install wizard, 32bit otherwise.

Share this post


Link to post
Share on other sites
I never looked at your log file put on the 32 bit ... the default is the 32 bit 

Share this post


Link to post
Share on other sites

First.. Thank-you for your help so far.

I think I'm getting there but I'm really stumped on the new problem, I hope someone has seen this before.

I have uninstalled and reinstalled PinballX and put in a new directory to make sure I didn't get any residual errors from leftover files or registry settings.

I have now set it up and I was getting the same thing (more or less) But I thought I'd try to switch the backglass to 1 as well as the playfield (they are both set as 1)

In the Pinballx frontend I have a normal view  flipping through tables except it just shows the desktop in the backglass (predictable, yes..) but if I load a table it sets up perfectly.

Including tables with pup packs and others with b2s or dmd. They all set up and run well and clear when I close them but I'm left with the desktop for a backglass in the front end.

In my computer display settings the playfield is 1 and the backglass is 2

I hope someone has seen this before cause I have no ideas

Thank-you

Share this post


Link to post
Share on other sites
I don't believe they both can be one but the back glass could be 2 3 4 or 5

Share this post


Link to post
Share on other sites

I know they both cant be set at 1. I think that is why I'm showing desktop when I'm in the front end but it is working when I load a table. 

I want to set it to 2 but the backglass doesn't load. I'm hoping to find out what will fix that

Share this post


Link to post
Share on other sites
The screen numbers in windows don't always match the ones in other programs

Share this post


Link to post
Share on other sites

Can you screen capture your Windows display settings with the monitors and attach?

Share this post


Link to post
Share on other sites

You are probably going to need to change your display settings in Windows. Assuming that the first monitor is oriented in portrait mode and is a 1080P monitor, it should be set for 1080x1920. Next, you will need to drag your 2nd monitor on top of the first.

Share this post


Link to post
Share on other sites

Try all the other options for the backglass screen number in settings one at a time, start and close pinballx between each. The backglass should show for one of the options 2,3,4, or 5

Share this post


Link to post
Share on other sites

I have just tried to change the orientation of the playfield and moving the placement of the backglass. The settings have always been 1920 x 1080 so I keep them at that.

I have tried to play the tables in all 5 monitor settings but the only place the tables load and set up dmd and b2s is playfield set at 1 and the backglass set at 1.

At those settings everything loads perfectly except pinballx doesn't show anything in the backglass monitor. just the desktop

 

Share this post


Link to post
Share on other sites

Thank-you for the ideas but none seem to work for whatever is going on.

I'm hoping someone has an idea that will work, but I'm totally out of ideas

Share this post


Link to post
Share on other sites

I did try that both ways . I also tried allow b2s in front end true and false..no change.

I'm finding myself trying the same thing over and over. Thank-you for the suggestions.

it in so odd, with them both set to monitor 1 in  the pinballx settings loading a game works perfectly but in the front end no b2s or  png backglass  or even a blank screen, just the desktop.

If I set the backglass to any other number 2,3,4,5 I can have a png or even a b2s but when I load the table the backglass never loads.

 

Share this post


Link to post
Share on other sites
1 hour ago, designone said:

 

If I set the backglass to any other number 2,3,4,5 I can have a png or even a b2s but when I load the table the backglass never loads.

 

Maybe stupid question, but did you check the option in gamemanager "hide backglass"?

Share this post


Link to post
Share on other sites

If you have the backglass showing in pinballx, with autopositionb2s=False, when you open a table can you ALT+TAB to see the hidden backglass in game? And what happens if you load again directly outside pinballx?

I think there's a mismatch between screen numbers for pinballx & VPX/B2S (set in screenres.txt file).. you may need to change screenres.txt to show b2s in game by relative position rather than by screen number, info on that in this post https://www.vpforums.org/index.php?showtopic=38775#entry406938

Share this post


Link to post
Share on other sites

Finally Solved...Thank-you all so much for your help,

When Mike da Spike  asked about  about checking the hide backglass I thought of course I did but then I recalled I had spent an hour messing with those settings but, that it was before I uninstalled the 64 bit and installed the 32 bit.

When I got home today I looked and they were checked off. I unchecked them and I'm going now. I had tried so many things in 64 bit and never thought about checking them again all after I reinstalled.

So thank-you all for your help ...I guess I was too close to the forest to see the trees.

That is why these forums are so great.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×