Jump to content
SpesoftPinballXConvert-It
blubberpud

[RESOLVED] Playfield turns green?!?

Recommended Posts

Hey!  I am in the process of building a cabinet, have 3 screens and when I launch a game from PinballX my playfield (Display1) turns green in the "Loading..." screen and colors are messed until I reset the resolution or reboot.  Has anyone seen this or have any recommendations?

Launching tables from VP9.92 - no issues

System Win7 64x / NVidia GTX 750 Ti

PinballX 3.28 (32bit) / VisualPinball 9.92 / VPM 3.1

Thanks in advance, Jay

20190208_152814.jpg

20190208_152946.jpg

20190208_153030.jpg

Share this post


Link to post
Share on other sites

Hi Jay - can you attach copies of your pinballx.ini and log.txt files for review?

Also, do you have any codecs installed? If none, you may want to install the LAV codecs found here.

Share this post


Link to post
Share on other sites

Does it stay green when playing in visual pinball or in windows as well when it happens or only inside pinballx ? If it's only in pinballx it's probably the codecs you need as draco pointed out. If it happens elsewhere i would also make sure to have latest video card drivers installed from nvidia themselves not the windows supplied ones.

  • Like 1

Share this post


Link to post
Share on other sites

Check drivers & codecs as suggested above, and as it appears to affect only one screen i'd check your cable/connections too.

  • Like 1

Share this post


Link to post
Share on other sites

I had the same with my Samsung Tv when starting the cab.

Removing the Hdmi and put back was a workaround 

During powering on of the cabinet, the pc started on a 4k 60hz resolution mode, but the TV was starting in 4k 30p. This gave me the same behaviour.

First as workaround I set the resolution to 4k 30hz when shutting down the pc and at startup of pbx I moved it to 4k 60hz again.

Finally I changed a setting in the Tv. Set it to pc mode (but that causes some lag) and another setting (that prevents the lag), but not sure what the setting was)

That fixed iyt for me

And use HDMI1 port !! 

Share this post


Link to post
Share on other sites
On 2/10/2019 at 1:31 AM, Mike_da_Spike said:

I had the same with my Samsung Tv when starting the cab.

Removing the Hdmi and put back was a workaround 

During powering on of the cabinet, the pc started on a 4k 60hz resolution mode, but the TV was starting in 4k 30p. This gave me the same behaviour.

First as workaround I set the resolution to 4k 30hz when shutting down the pc and at startup of pbx I moved it to 4k 60hz again.

Finally I changed a setting in the Tv. Set it to pc mode (but that causes some lag) and another setting (that prevents the lag), but not sure what the setting was)

That fixed iyt for me

And use HDMI1 port !! 

Thanks everyone for your helpful responses!

It ended up that I was plugged into the side HDMI2, switched it over the HDMI1 on the back and seems to be stable with no lag :)

  • Like 2

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×