Jump to content
SpesoftPinballXConvert-It
Mike_da_Spike

[RESOLVED] Creating videos in 4k at 15fps ?

Recommended Posts

I just switched over from a Fullhd playfield to a 4K playfield.

When I create video's in 4k (especially the FX3 tables) the table movement is not smooth

Checking the frame rates of the captured video I see that the 4k (3840x2160) ar captured with 15 fps and the fullHd (1920x1080) at 30 fps

Is is possible for me to set the fps for 4k higher than 15 fps?

image.png.8a0efc138481fff7e6ff4f76fa6fd139.png

 

(Sorry for my Dutch version of Windows ...)

The logfile shows an ffmpeg capture of 15 fps:

log.txt

PinballX.ini

Share this post


Link to post
Share on other sites

I have a Nvidia  rtx 2070. 

How do I enable the driver capture option ?

Is that the option in the settings under video capture?

Share this post


Link to post
Share on other sites

I've setup in my Geforce Experience the capture setup. Also changed  in the Video settings to use GPU for capturing, but still it is using FFMpeg with 15Fps

If I hit Alt-Z it is launching the video settings overlay, and I can press a manual record. That is working fine

 

log.txt

PinballX.ini

 

 

 

Share this post


Link to post
Share on other sites

Did you set the correct keys for capture? Is the save location correct for Geforce Capture? You have it set as: C:\pinball\Pinballx. Is this where Geforce is set to save them?

From the log it looks like its not even attempting GeForce capture.

Share this post


Link to post
Share on other sites

Awesome Tom !

I made a mistake.

If I select in Geforce experince a folder, I normally dubbelclick that foler. but than it uses a subfolder.

Just browsinf (for me) to c:\pinball and select pinballx did the trick !

Now it is capturing correctly.

 

I will write down a little manual, so that others can use this too. (maybe it's already there, but could not find it)

Thakns Tom for helping me out on this ! I really appriciate all your work you put into this nice front end tool and helpgin people on this forum !

:cheers:

 

Share this post


Link to post
Share on other sites

Using Geforce Experience driver to capture video's within PBX :

Open your Geforce experience 

  • Press Alt+Z to bring up the Share overlay and go to Settings :

1.thumb.png.a5f682e2e889e00298af822f1a6fe284.png

NOTE: If the Share overlay does not appear it may be turned off. You can turn it on inside GeForce Experience by going to Settings > GENERAL > SHARE and toggling the switch. It will light up green indicating the Share overlay has been turned on.

  • In Settings, click on Recordings:

 2.thumb.png.61ccf519739dbbe695d8b980446a0a6d.png

  • Set the path where the video’s will be recorded. For example c:\pinball\pinballx\GeforceCapture

3.thumb.png.b07f5affdc203c7f18ce5ac7a970c1db.png

 

  • Hit the Back button and hit Done
  • Check under Records what the key is to start a record. By default it is Alt+F9

4.thumb.png.1a7c9467c378f2ca7d4e87a0ff29f2c9.png

  • Close the Share Overlay
  • Open PinballX Setup Wizard and select Video recording in the left pane

5.thumb.png.ee32752a4de73099c871fb15a6a8ece2.png

  • Select  Use GPU driver capture to Yes
  • Make Sure that the Driver record start/stop key are the same as the hotkey that is defined in the Geforce Experience Share overlay screen
  • Set the Driver save path to the same directory as the Recording path in the Geforce Experience Share overlay screen
  • Save your settings !

 (sorry for the Dutch Screenshots, but could not set it to English)

 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for sharing your guide for this!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×