Jump to content
SpesoftPinballXConvert-It
laggerific

No Emulators in Attract mode

Recommended Posts

I'm really sorry. I've been incredibly busy. Hopefully for the next update.

 

Thanks.

Tom

Share this post


Link to post
Share on other sites

Great Tom thank you I really do appreciate everything you’re doing. 

Share this post


Link to post
Share on other sites

I had a chance to look at this today. Its working for me perfectly in the latest release. Which should be out today.

Thanks.

Share this post


Link to post
Share on other sites

Hi,

How do I check what version of GameEx I'm running?

Share this post


Link to post
Share on other sites

Should show in Windows Control Panel>Programs and Features.

Share this post


Link to post
Share on other sites

I'm running GameEx 15.61 and its still not showing other Emulators in Attract Mode besides Videos and Mame.

Share this post


Link to post
Share on other sites

I didn't test with videos running too but the randomness is based on the total number of games. So if you only have a few hundred games from other emulators, 5000 games in MAME will always take precedence. If that is not the case, please disable videos and report back.

Also note that there is a global option to enable other emulators in attract mode. did you select that?

Thanks.

Tom.

Share this post


Link to post
Share on other sites

I disabled videos and it still just shows Mame games. (been on for a couple of hours)

Everything is enabled. This used to work and I don't know what version stopped working because I had my machine off for a few months an I updated it once I turned it back on.

I've Attached my log file if that helps.

Thank You

log.txt

Share this post


Link to post
Share on other sites

I think I can see the problem.

You are using some unsupported databases for emulators 22 and 23. Please disable the databases for those systems and let me know the results.

Thanks.

Share this post


Link to post
Share on other sites

Ok I've removed those lines. But those emulators (19-23) are set to NOT show up in attract mode. (Its a custom Karaoke song list setup)

I really haven't changed anything within my emulator setups that would effect attract mode. It always just worked.

I'll let it run over night and resend my log if it still doesn't work.

 

Thanks Tom

Share this post


Link to post
Share on other sites

I hear you. I think that's the issue though. Like with any software thimgs get improved and move forward, and some programs or data for those programs become legacy and unsupported as the system cannot still operate if it has to support them..

Bssically those databases are missing the developer field.

Ill likely fix the issue now its been identified.

Share this post


Link to post
Share on other sites

Good Morning.

I left it running over night and watched it this morning for a while and I didn't see anything new. 

I looked at the log and I see lots of "exceptions" when loading Emulators other than Mame.

Obviously you can decode the log file and I can't, but is there anything else I need to try?

log.txt

Share this post


Link to post
Share on other sites

Have you downloaded/installed the latest v15.62 ? Not sure if it addresses the issue but Tom just released it this morning.

Share this post


Link to post
Share on other sites

No, nothing in the latest release would affect it.

Im pretty stumped on this. Can you please try disabling all plugins?

Thanks.

Share this post


Link to post
Share on other sites

I disabled all plugins and still nothing. I went and cleaned up my settings (things that gave errors when verifying) and disabled troublesome emulators and I'm watching it now and its always Mame.

 Have you had a chance to see if it works for you @laggerific ??

 

Ive added my GameEx.ini and Log file.

log.txt GameEx.ini

Share this post


Link to post
Share on other sites

Hey,

I am going to PM you with a debug version. Give me a bit. Sorry about the hassle.

Cheers.

Tom.

Share this post


Link to post
Share on other sites

Hi,

I've updated to the past few updates (not sure what they were because there were no release notes) and somewhere along the way my Atari 2600 games started showing up in attract mode.... but none of the others. 

I still have videos and plugins disabled. 

So as of right now I have Mame and Atari 2600 (Stella) showing up.

I've attached my log and Gamex.ini

log.txt GameEx.ini

Share this post


Link to post
Share on other sites

The same issue definitely does not seem to be happening here now,,

Looks like its working as it should apart from the io error.

I see Atari 5200 launching too. Looks lime emulator 11 has an issue though.

Share this post


Link to post
Share on other sites

Hi, 

I'm still having issues with it not showing other emulators, but I'm going away for awhile so I'll have to shut down my system. Maybe I'll try Evolution when I get back to see how that works. 

Thanks Tom

Share this post


Link to post
Share on other sites

Hi,

I still don't have other Emulators in attract mode. I've been trying all kinds of things and maybe I'm wrong but could it have to do with unzipping?

How does Attract Mode work? Could you break it down for me?

I see the file "runitgame.bat" is created, it has info when Mame or Atari 2600 games load in Attract mode (only systems that run in Attract)


chcp 65001
E:
CD "E:\Emulators\Atari\Stella"

Stella.exe -gl_fsmax 1 -fullscreen 1 "E:\Games\No-Intro\Atari - 2600\Cookie Monster Munch (USA).zip"

I also see "runit.bat" and it gets created when ever an emulator is trying to load in Attract mode. So is thise file working right?

Trying to load SNES in Attract;


chcp 65001
C:
CD C:\Users\NN\AppData\Local\Temp\Unzipped7-Zip
"E:\Emulators\Arcade\GameEx\7za.exe" l "E:\Games\No-Intro\Nintendo - Super Nintendo Entertainment System\Yamaneko Bubsy no Daibouken (Japan).zip" > "C:\Users\NN\AppData\Local\Temp\Unzipped7-Zip\list.txt"

Trying to load Genesis


chcp 65001
C:
CD C:\Users\NN\AppData\Local\Temp\Unzipped7-Zip
"E:\Emulators\Arcade\GameEx\7za.exe" l "E:\Games\No-Intro\Sega - Mega Drive - Genesis\Phelios (Japan).zip" > "C:\Users\NN\AppData\Local\Temp\Unzipped7-Zip\list.txt"

 

If I look in "C:\Users\NN\AppData\Local\Temp\" it doesn't have "Unzipped7-zip" but if I create it and load the last 'runit.bat" I see the "list.txt" file. 

There is no SNES rom in the "Unzipped7-zip" folder but there was a Genesis one when it tried to run.

 

So what is supposed to happen here? Does this all make sense?

From what I'm gathering, Attract mode starts, it uses "runit.bat" to unzip the rom and then it uses "runitgame.bat to load the extracted rom. If this is correct, what is the purpose f the "list.txt" file creates?

Could something be wrong with 7zip? Something wrong with the location of the extracted roms? Permissions? 

This is driving me CRAZYYYYYY :wacko:

 

Thanks for reading all this.

 

 

UPDATE:

I see that "runit.bat" tried to extract another SNES rom and this time the rom WAS in the "Unzipped7-zip" folder but there was not "list.txt" file. Also the Game did NOT show up in Attract mode. 

 

 

 

 

 

log.txt

Share this post


Link to post
Share on other sites

So its confirmed this is a problem with unzipping the roms. I turned off Zip support in GameEx and all of a sudden the Emulators started working in Attract mode. 

Is there anyway to change the folder where the roms get unzipped so I can see if it has something to do with permissions?

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

I thought I would retest my setup to (hopefully) give another perspective...but after upgrading to GameEx 16.06, I cannot get Attract Mode to trigger at all, not in 'Time and Weather' mode, 'Videos Only' mode, 'Standard GameEx Screensaver (Mame Only)' mode, and certainly not for emulators. The log.txt file does not reflect attract mode is triggering.

I rechecked the parameters in the gameex.ini file to make sure the Setup Wizard and the config are matching and saving properly, and they appear to be. I've attached the log.txt for the last test, 'Standard GameEx Screensaver (Mame Only)' mode.

Tom: I am not looking for a fix for my setup, only looking to help out the troubleshooting. If you can spot anything wrong with my config, please let me know...I assume GameEx is seeing something happening on my rig that causes it to think it is not idle. I will take suggestions on that too. If my involvement may make things more challenging, let me know and I can bow out.

GameEx.ini log.txt

Share this post


Link to post
Share on other sites

Sorry for the delay. I generally cant duplicate any issues though. I will test with your specific settings shortly. Does it work if running manually?

As for the op, did I suggest deleting the data\emu*.map files?

Share this post


Link to post
Share on other sites
On 11/29/2019 at 1:18 AM, Tom Speirs said:

Does it work if running manually?

I assume this question was aimed at me. Yes, I am able to launch Mame games via GameEx, which is what my log.txt is based on.

When I tested with other emulators, I used NES (nestopia) and Sega Genesis (Fusion) and they both launched successfully via GameEx as well.

Then again, my attract mode isn't triggering at all, so perhaps mine will not be helpful towards the op's problem.

 

Share this post


Link to post
Share on other sites
8 hours ago, RedDog said:

I assume this question was aimed at me. Yes, I am able to launch Mame games via GameEx, which is what my log.txt is based on.

When I tested with other emulators, I used NES (nestopia) and Sega Genesis (Fusion) and they both launched successfully via GameEx as well.

Then again, my attract mode isn't triggering at all, so perhaps mine will not be helpful towards the op's problem.

 

Yes.

I was referring to the "Run Screensaver" menu option in regards to manually running. That will determine if it is the timer/detecting input or an issue with the screensaver itself.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...