Jump to content
SpesoftPinballXConvert-It
funkydmunky

[RESOLVED] GameEx Arcade setup

Recommended Posts

Okay I'm back running.

I have DL'ed and installed 15.5. GameEx Arcade now runs which is a good step. But of course with me everything can't go that smooth LOL.

Issue is when I select a game to play it will not launch. Simply goes to a blank screen for 10 seconds then a return to the Play This Game screen.

As always any help is appreciated.

 

GameEx.ini

log.txt

Share this post


Link to post
Share on other sites

Hey funky,

You have a space inbetween the hypen and ctrlr command in the Mame Options line: "- ctrlr X-Arcade". Remove the space. The rest looks ok.

Also, I am not sure if the X-Arcade option is still supported by Mame. I used to have a legacy X-Arcade stick a few years back and had trouble making it work. I recall having to go with the keyboard emualtion instead. If removing the space above does not do it, try removing the ctrlr option all together as a test.

Share this post


Link to post
Share on other sites

Hi RedDog.

Removed the space and there is some minor change. Now when launching it shows brief moments such as Initializing, Loading etc... like normal when a ROM is loading but then the simple black blank screen as before. This time it doesn't return to the Play Game Now screen. Right flipper two player buttons will get me out.

Okay on exit I get this message "Fatal error. Could not load controller file X-Arcade.cfg"

Interesting as I have always used this controller through various versions of GameEx arcade. Never had any issues. As of right now it controls the front end menus just fine. Even allows me to back out of the crash. It also works just fine with my MAME install outside of GameEx. I set it up and tested MAME before adding GameEx.

 

Removed the "-ctrlr X-Arcade" and the ROMs load.

Edited by funkydmunky
Added info

Share this post


Link to post
Share on other sites

Did you recently update MAME and do you have an x-arcade.cfg file in your \MAME\Ctrlr folder? Have you configured your mame.ini file in the CORE INPUT OPTIONS section to show ctrlr =  X-Arcade as in the section displayed below?

#
# CORE INPUT OPTIONS
#
coin_lockout              1
ctrlr                     X-Arcade
mouse                     1
joystick                  1
lightgun                  0
multikeyboard             0
multimouse                0
steadykey                 0
ui_active                 0
offscreen_reload          0
joystick_map              auto
joystick_deadzone         0.3
joystick_saturation       0.85
natural                   0
joystick_contradictory    0
coin_impulse              0

Share this post


Link to post
Share on other sites

Hi there Draco1962.

Yes I have an Xarcade.cfg in my MAME directory. I tested and ran MAME before I added GameEx Arcade. I simply select XArcade from the controller option. As far as CORE INPUT OPTIONS I don't know what that is. X-Arcade has always worked on every version of GameEx Arcade I have tried. It also works with MAME once I select it.

The X-Arcade works in GameEX Arcade with the "-ctrlr X-Arcade" added to MAME settings. The sticks and buttons all work correctly, EXCEPT somehow it is preventing a launch of a ROM. The controller is correctly mapped as even after the failed ROM launch I can back into the menu screen using the escape button sequence and the controller continues to work as normal.

Share this post


Link to post
Share on other sites

Ok, a little confuzzled and I'll tell you why. You mention having "Xarcade.cfg" in your MAME directory. The command line is calling for "-ctrlr X-Arcade" so you have to decide which .cfg file you are actually trying to call. If you are using the command line switch - ctrlr  X-Arcade then you need to have a file in your ctrlr folder named X-Arcade.cfg. If not, then you will error.  You may want to try renaming your Xarcade.cfg file to x-arcade.cfg to see if that works.

I am not sure what version of MAME you are running. I am running an X-Arcade Tankstick flawlessly against MAMEUI64 (version 0.199) with the ctrlr X-Arcade in the mame.ini file, the x-arcade.cfg file in the mame\ctrlr folder, and using  the command line switch - ctrlr  X-Arcade

Share this post


Link to post
Share on other sites

Draco1962 you are the MAN!

Renamed it to match and it works. So odd that I have never had to do this before.

Thanks for everyone's help and the updates.

Now onto PinballX! Hope that goes a little smoother LOL

Share this post


Link to post
Share on other sites

Glad that you got it sorted and I was able to help.

Share this post


Link to post
Share on other sites

I'm new here, I apologize if this is the wrong place to post my question but I saw others here reporting problems. Let me know if this is the wrong place.

My question is how do I disable the pop-up information that comes up when I highlight a game in MAME? I've tried looking over the guide for the Wizard Setup and it must not be the one for the Arcade Edition, it shows a disable pop-up on the online guide but nowhere in the settings I have for the Arcade edition. I'm disabling it because its causing problems with the snap videos, in case anybody was wondering.

Any directing me in the right place to disable the pops, would greatly greatly appreciate it. Thank you.

-Nick

Share this post


Link to post
Share on other sites

Speaking about GameEx Arcade, does it support load/save states? It does not load and save the states. Is this a setup or is this not supported?

Share this post


Link to post
Share on other sites

Please start your own specific topics for your support questions.

Thanks!

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×