Jump to content
SpesoftPinballXConvert-It
funkydmunky

GameEx Arcade setup

Recommended Posts

I've gone to downloads and installed latest version each time I was informed it was updated. Might have been a slip up do to no revision numbers in the file name. I could have accidentally re-installed the Aug 20th version as that is showing as the date last downloaded. Placing version #'s on the file name would be a kind request.

Just downloaded latest version of GameEx Arcade. Setup consisted of only directing it to MAME and ROMS. Attract mode still flips the screen. No change.

 

GameEx.ini

Share this post


Link to post
Share on other sites

Sorry for the trouble but I still think you may be using an older version. The version number is shown in the log, when installing and on the site.  Ill need you to post the log again please. I just cant duplicate this issue since I fixed it (or thought I did).

Share this post


Link to post
Share on other sites

Hey funky, would you post your most recent log.txt file as well? You can make a new post or attach it to the above post. It would help us confirm that your upgrade was indeed successful. Thanks.

Share this post


Link to post
Share on other sites

Hi, I am really sorry. There was an issue and the 64 bit exe was not updating. Its fixed in 15.38 and will be available in a few minutes.

Thanks.

Share this post


Link to post
Share on other sites

The new GameEx arcade will not launch. Uninstalled, rebooted, reinstalled twice. Same result.

 

Edit. I have reverted back to the last GameEx Arcade and now it will not launch either. This is a dedicated GameEx Arcade build. Could the GameEx reg key have an install limit or something?

Share this post


Link to post
Share on other sites

Hey funky, there may be a launch issue with 15.39. See this thread.

  • Thanks 1

Share this post


Link to post
Share on other sites

Funky, GameEx Arcade 15.40 is now available and should fix the launch issue you experienced. Would you upgrade and give it a try?

Then you can get back to see if Tom's fix for the attract mode/screen flipping has improved.

Share this post


Link to post
Share on other sites

GameEx.exe 15.40 will not launch. GameEx_Background.exe will. I don't know what the difference is.

As far as the Attract mode goes, it appears to be fixed and working. It does jump to the desktop between games but I think there is a setting for that.

 

Share this post


Link to post
Share on other sites

If I recall correctly, GameEx_Background.exe is what downloads assets in the backgorund when you first launches. It may also do other tasks too (not sure). I've never actually tried to launch it manually, but I just did and it did indeed launch GameEx Arcade. I have no idea if that is intentional, but I assume it is sicne it does work. Tom may need to chime in.

GameEx.exe and GameEx_Lite.exe are the executables that you would normally use to launch GameEx Arcade. If you cannot launch using either of them, you may want to post the resulting log.txt and any error dialogue that appears. Maybe it is something related to the Ultimate version of Windows 7 64 bit.  The new vesion worked fine for my Windows 7 home 64 bit.

 

 

Share this post


Link to post
Share on other sites
10 hours ago, funkydmunky said:

GameEx.exe 15.40 will not launch. GameEx_Background.exe will. I don't know what the difference is.

As far as the Attract mode goes, it appears to be fixed and working. It does jump to the desktop between games but I think there is a setting for that.

 

Try turning off run in background under online settings. Its a known issue.

Share this post


Link to post
Share on other sites

Turning off run in background had no effect. GameEx.exe will not launch. GameEx_Background.exe continues to launch without issue.

I'll have to ask this again, what is the difference between the two and any negatives to me running GameEx_Background.exe?

Share this post


Link to post
Share on other sites

I should note that I always FULLY uninstall old versions before installing the latest build. I am always concerned that there might be some errors from not doing so. Clean installs every time.

Share this post


Link to post
Share on other sites
15 hours ago, funkydmunky said:

I should note that I always FULLY uninstall old versions before installing the latest build. I am always concerned that there might be some errors from not doing so. Clean installs every time.

Probably not recommended as GameEx will update all files that require an update and you run an unnecessary risk of losing your configuration settings. Additionally, you should run gameex.exe to start GameEx.

If you have updated to the latest version and it is newer than the version you initially reported, please attach copies of the latest gameex.ini and log.txt files.

Share this post


Link to post
Share on other sites

Hi Draco1962. I did fresh installs because of the continuing problems I am having, as to isolate each build. Yes loosing my configuration setting each time sucks!

I am quite familiar with how to launch GameEx. Are you providing some insight to the situation that I'm not understanding? Any help is welcome. I currently have a non functioning GameEx Arcade. GameEx_Background.exe will launch into GameEx front-end but fails to launch ROMs. As stated previously, GameEx.exe will not launch at all. I have done multiple re-installs.

Thanks for reminding me about adding log/config files. It was fast and furious for a bit and that got missed.

If I could request some old versions to try. I have never had this issue in the past. My near two year old cabinet worked flawlessly with GameEx demo. Now that I have upgraded, not so much.

GameEx.ini

log.txt

Share this post


Link to post
Share on other sites

Sorry if its a stupid thing to ask but please try and downloads and install again the latest version.

The two executables are exactly the same so there is no reason why one wouldn't work "unless" its already running (check task manager).

Share this post


Link to post
Share on other sites

I have done multiple times Tom. There is nothing obvious in the Task Manager of anything GameEx related. It has been two(?) versions in a row I have had this issue of non launching GameEx. Nothing happens not even a flicker. GameEx_Background.exe  used to work on the last build but now it will launch GameEx but no ROMs. That is why I do full uninstall, re-install. But I feel there might be issues remaining even after a full uninstall. This is why previously I had asked about .reg entries that I could delete to insure clean installs.

I might just reinstall Win7 tonight. It is a dedicated cab so it shouldn't need to be, but you never know. It sounds like I am the only one having this issue so I might as well do so. Then I can make sure, or not, if it is a problem on my end.

Share this post


Link to post
Share on other sites

Good, yet bizarre news, I seemed to have had a failing SSD (failed?)

I have not done much investigation yet other then a fresh install on Win7 and GameEx Arcade. But it launches so it is a win.

Quite the oddest thing I have ever seen in a while. No error messages etc... Only on this last build did I ever have a difference in complications from others.

Anyways up-wards and on-wards!

I haven't tested anything yet, but I thought it important to update the community as to my status. GameEx Arcade launching.

Share this post


Link to post
Share on other sites

Any form of copy protection that may relate to my circumstances? This is all quite bizarre, including the complete lack of dialog from what I consider basic questions.

Share this post


Link to post
Share on other sites

Running your gameex.exe as adminstrator?

Share this post


Link to post
Share on other sites
10 hours ago, funkydmunky said:

Any form of copy protection that may relate to my circumstances? This is all quite bizarre, including the complete lack of dialog from what I consider basic questions.

I don't discuss such thimgs in public for obvious reasons but there shouldn't be. What lack of dialog? I thought I was working pretty hard to help you?

Share this post


Link to post
Share on other sites

I'm a bit rusty these days, but here are some suggestions:

First, if you have Rptr, Gaming Evolved installed as part of your Catalyst installation, uninstall it.  It causes problems with GameEx. 

 

It's been a while for me on the system pack side of things, but I do recall that you must follow it through step by step exactly as it's outlined in order.  It worked perfectly for me when I last installed it.

The paths do not matter, and if you let the system pack do its thing, then just follow whatever it defaults to.  There is no guide I'm aware of for this, Tom simply created these for people who didn't want to hunt down artwork, snaps and the like.  It is simply provided as a convenience for GameEx subscribers.

 

As Tom mentioned, your directories can be anything.  C: \Chocalate\snaps,:P literally anything.  As long as you point the setup wizard to them, it doesn't care, and what's in there by default are merely suggestions.  If there are things in the wizard you don't have, skip them.  It only uses the resources you direct it to use.

 

I run mostly GameEx proper, so in referring to that, ensure that you are running integrated mame.

This guide needs to be updated to come up to speed with the newer setup wizard, but this is the section.

Complete it through the "advance mame settings"  

 

 

Don't confuse AdvanceMame with advance mame settings.  You only need to worry with this section if you're running advancemame.

 

By using the integrated MAME support you need not work about any "MAME" stuff in the emulator section, your not running it as an emulator. 

 

The integrated MAME support will do everything you need it to, assuming you've got your directories correct.

You should have to update each time you change something while using integrated MAME, but only upon a change.

 

 

Share this post


Link to post
Share on other sites

Nice to meet you tthurman.

Very old Radeon 4830, so no special shit. Basic driver as that is all offered. ;)

Thanks for the advice. I will see what I can do with it. Lots of good points to follow.

All my drives are corrupt and I'm working on it. I hit a total low and am rebuilding. Nice of you to reach out.

Share this post


Link to post
Share on other sites

This may save you some effort and hair pulling should this occur again, or at least provide a good starting point before throwing in the towel.  This has saved me many a time!

If you ever move to Windows 10, you can use the media creation tool to download the latest patched image and check against it.  There could be similar avenues for 7, but I am not familiar with them.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×