Jump to content
SpesoftPinballXConvert-It
Gildahl

Loss of joystick input in 15.32

Recommended Posts

Hi Tom,

I just updated to 15.32 and I am experiencing loss of joystick input again (as well as my other two open issues).  It's a little different this time.  Originally joystick control was gone upon loading GameEx.  This time jJoystick works fine at first, but after playing a game for a while and returning to GameEx, joystick control is gone.  I use Ultrastick 360s.

So to recap open items.

1.  Loss of joystick control (but only after returning from a game).
2.  Loss of interface sounds after returning from games (game sounds and video snapshot sounds still work). Restarting GameEx gets sound back temporarily.
3.  Loss of Daphne game list in my custom menu.

Dave

log.txt

GameEx.ini

CustomMenu.ini

Share this post


Link to post
Share on other sites

Hey,

I have not looked at the Daphne issue yet, but is it a particular emulator causing a problem as I cant duplicate eh audio or gamepad issue?

Share this post


Link to post
Share on other sites

I did a little more testing today.  The joystick issue is hard to pin down.  When I started up today, all was good (joystick & sound), after playing a bit of Asteroids I returned to GameEx and found the joystick not working; however, after a few moments it started working again.  After playing some more, most of the time the joystick would be ok after returning to GameEx, but I did encounter one more "delay" of about 5 seconds of dead joystick before it became functional again.  So I can see how this might be hard to duplicate.  It has definitely never done this sort of thing before 15.30 though.

Regarding sound, interface sounds (clicks and chimes) are always fine upon first loading GameEx but are gone for good after returning from pretty much any game.  As I reported earlier, sound from video snaps still work in the interface and sound in games is fine, it's only the interface sounds that disappear.

Share this post


Link to post
Share on other sites

Just to follow-up, I deleted the whole contents of the GameEx folder (just the files in the root, not the subfolders) and replaced the contents with a backup from 15.27 and both the joysticks and sound seem to work fine/normal (unfortunately, however, the Daphne issue is still there).  As soon as I revert back to the 15.32 files again, the sound and joystick issues return (I can at least now confirm that when it happens the joystick remains dead for about 5 to 10 seconds after returning from a game). 

I should also remark that just replacing the GameEx.exe with the 15.27 .exe does not fix the issue, it is only when I replace all the files in c:\GameEx with the ones from 15.27 that the problem goes away.

Share this post


Link to post
Share on other sites

I did change libraries between those versions so it would explain it. I will have to post you a version with some logging to help troubleshoot the issue. As for audio Ill just try reinitilaing after coming back from game launch. Ill get back to you.

Tom.

Share this post


Link to post
Share on other sites

Hi Tom,

Just a note that I updated to 15.34 today and still get loss of interface sound after returning from some games back to GameEx.  It doesn't happen with all games, but Visual Pinball X seems to be the most reliable in killing the interface sounds.  As before, if I revert the files in the c:\GameEx folder back to those from 15.27, I have no issues.

I didn't test extensively, but didn't notice any joystick issues this time, so maybe that's fixed now?  I'll follow-up if I see that again.

Also, on the Daphne issue that I was having, that seems to be resolved.  On a whim I toggled the switch in the Wizard to disable then enable Daphne and the games now show up again, so it was just something funky in the configuration that seems to have happened after a recent update.

Share this post


Link to post
Share on other sites

Thanks for reporting back. I've not done much on your issues but will try to make audio reinitialize on return from game.

Share this post


Link to post
Share on other sites

Hi @Tom Speirs: Just to throw my hat in the ring, I have the missing audio when returning from a game as well. Nothing suspicious in the logs.

After I run a game and use ESC to exit the emulator, all my GameEx menu sounds are gone. I also lose my pagination controls on the joystick, although the menu nav controls and the confirm/cancel buttons still work. I can reproduce this reliably every time I exit a game.

23:12:33.18  7/10/2018:  Opening Configuration File
23:12:33.20  7/10/2018:  GameEx: Version 15.34: Starting Log
23:12:33.28  7/10/2018:  Windows 10 Pro 64-bit
23:12:33.28  7/10/2018:  Aero running
23:12:33.29  7/10/2018:  Initializing Vista/Windows 7 volume control
23:12:33.30  7/10/2018:  Getting CPU and RAM info
23:12:33.30  7/10/2018:  Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz, 32601MB
23:12:33.31  7/10/2018:  3.49Ghz - 8 Cores or CPU's
23:12:33.31  7/10/2018:  Running Randomize()
23:12:33.37  7/10/2018:  Loading PlugIns
23:12:33.38  7/10/2018:  Loaded Plugin:"Game Info Plugin" Version 1.3.6 By Adultery
23:12:33.84  7/10/2018:  PlugIn: "Game Info Plugin" Initialized OK
23:12:33.84  7/10/2018:  Using Plugin System Version: 1.41
23:12:33.99  7/10/2018:  Loaded Plugin:"Game Tagger" Version 1.1.5 By Adultery
23:12:35.69  7/10/2018:  PlugIn: "Game Tagger" Initialized OK
23:12:35.70  7/10/2018:  Using Plugin System Version: 1.41
23:12:35.71  7/10/2018:  Loaded Plugin:"Hi-Score Snapper" Version 1.0.8 By Adultery
23:12:37.10  7/10/2018:  PlugIn: "Hi-Score Snapper" Initialized OK
23:12:37.11  7/10/2018:  Using Plugin System Version: 1.41
23:12:37.12  7/10/2018:  Checking for applications to Launch On Startup
23:12:37.13  7/10/2018:  Setting default net connection limit to 15
23:12:37.13  7/10/2018:  Running Misc startup tasks
23:12:37.13  7/10/2018:  Setting Menu types
23:12:37.14  7/10/2018:  Getting Configuration Values
23:12:37.14  7/10/2018:  Using Theme: MegaMAME
23:12:37.14  7/10/2018:  Checking for alternate Image Directory for Theme: MegaMAME
23:12:37.15  7/10/2018:  Launching HideOS.exe
23:12:37.15  7/10/2018:  Initialising Video/MNG DLL's
23:12:37.15  7/10/2018:  GameEx will check for media insertion (may affect performance)
23:12:37.16  7/10/2018:  Hiding Taskbar
23:12:37.16  7/10/2018:  Using Cabinet Friendly Control System
23:12:37.17  7/10/2018:  Is Media Center running?
23:12:37.18  7/10/2018:  Checking/Creating LCD Registry values
23:12:37.18  7/10/2018:  Check Media Center Exit/Start Mode
23:12:37.18  7/10/2018:  Media Center Mode 2
23:12:37.20  7/10/2018:  Video previews on. Warning: Only recommended on modern systems
23:12:37.20  7/10/2018:  Custom Game Device Input enabled: Getting custom codes
23:12:37.21  7/10/2018:  Snap Delay set to: 4
23:12:37.21  7/10/2018:  Get other settings
23:12:37.21  7/10/2018:  Set: Find emulator artwork on best match basis
23:12:37.22  7/10/2018:  Start work for Form
23:12:37.22  7/10/2018:  Getting Original Screen Size
23:12:37.23  7/10/2018:  Opening Database Connection
23:12:37.23  7/10/2018:  Data Source=C:\GameEx\DATA\data.db3;Pooling=true;FailIfMissing=true
23:12:37.28  7/10/2018:  Initializing Component
23:12:37.29  7/10/2018:  MAME Path is: E:\Emulators\Mame
23:12:37.30  7/10/2018:  MAME EXE file is: mame64.exe
23:12:37.30  7/10/2018:  ROM Path is: T:\Roms\MAME\roms
23:12:37.31  7/10/2018:  Catver.ini is located at: C:\GameEx\DATA\catver.ini
23:12:37.31  7/10/2018:  controls.ini is located at: C:\GameEx\DATA\controls.ini
23:12:37.35  7/10/2018:  History.dat is located at: C:\GameEx\DATA\history.dat
23:12:37.35  7/10/2018:  nplayers.ini is located at: C:\GameEx\DATA\nplayers.ini
23:12:37.36  7/10/2018:  command.dat is located at: C:\GameEx\DATA\command.dat
23:12:37.36  7/10/2018:  MAMEinfo.dat is located at: C:\GameEx\DATA\mameinfo.dat
23:12:37.37  7/10/2018:  Loading Controls.ini map file
23:12:37.37  7/10/2018:  Snap Path is: E:\Artwork\MAME\Snap
23:12:37.37  7/10/2018:  Database Snap Path: Not Found
23:12:37.38  7/10/2018:  Background Snap Path: Not Found
23:12:37.38  7/10/2018:  AVI Snap Path is: E:\Artwork\MAME\Video_MP4
23:12:37.38  7/10/2018:  Flyer Path is: E:\Artwork\MAME\Advert
23:12:37.39  7/10/2018:  Cabinet Path is: E:\Artwork\MAME\Cabinet
23:12:37.39  7/10/2018:  Cabinet 3D Path: Not Found
23:12:37.39  7/10/2018:  Title Path is: E:\Artwork\MAME\Title
23:12:37.40  7/10/2018:  Title Path is: E:\Artwork\MAME\Logos
23:12:37.40  7/10/2018:  PCB Path is: E:\Artwork\MAME\PCB
23:12:37.40  7/10/2018:  Artwork Preview Path: Not Found
23:12:37.41  7/10/2018:  Panel Path: Not Found
23:12:37.41  7/10/2018:  Manual Path is: E:\Artwork\MAME\Manual
23:12:37.41  7/10/2018:  Icon Path is: E:\Artwork\MAME\Icon
23:12:37.42  7/10/2018:  Marquee Path is: E:\Artwork\MAME\Marquee
23:12:37.42  7/10/2018:  Applying Language/Text
23:12:37.43  7/10/2018:  Text/Language: English
23:12:37.44  7/10/2018:  Loading Language/Text
23:12:37.45  7/10/2018:  Loading Addins
23:12:37.45  7/10/2018:  Using Version 3 Themes Animations
23:12:37.45  7/10/2018:  Retrieving resolution setting
23:12:37.46  7/10/2018:  Using General Font: Tahoma
23:12:37.46  7/10/2018:  Using Title Font: Tahoma
23:12:37.47  7/10/2018:  GameEx will try to reduce CPU usage
23:12:37.52  7/10/2018:  Initialising Direct3D
23:12:37.74  7/10/2018:  Applying GameEx is Loading Image
23:12:37.77  7/10/2018:  Setting Resolution to 1920x1080 32 bit color
23:12:37.78  7/10/2018:  Creating Surfaces
23:12:37.93  7/10/2018:  Creating Back Buffer
23:12:37.94  7/10/2018:  Version 2 Theme being used. Loading.
23:12:37.95  7/10/2018:  Loading Button Data
23:12:37.95  7/10/2018:  Loading Font Data
23:12:37.95  7/10/2018:  Loading Layout Data
23:12:37.96  7/10/2018:  Loading Taskbar Data
23:12:37.96  7/10/2018:  Loading graphic Surfaces
23:12:37.97  7/10/2018:  Display is running at: 1920x1080 32bit color, 60hz
23:12:37.97  7/10/2018:  Adapter: NVIDIA GeForce GT 730
23:12:37.98  7/10/2018:  Max texture size: 16384x16384
23:12:37.98  7/10/2018:  Available texture memory: 4056MB
23:12:38.01  7/10/2018:  Available video memory: 2176MB
23:12:38.09  7/10/2018:  Initialising Bass Audio Library
23:12:38.11  7/10/2018:  Creating Surfaces Misc and Dialogs
23:12:38.16  7/10/2018:  Creating Surfaces Volume
23:12:38.16  7/10/2018:  Creating Surfaces Arrows
23:12:38.17  7/10/2018:  Creating Surfaces GameEXlogo Text
23:12:38.17  7/10/2018:  Creating Surfaces Toolbar
23:12:38.21  7/10/2018:  Creating Surfaces Toolbar Controls
23:12:38.22  7/10/2018:  Creating Surfaces Backgrounds
23:12:38.23  7/10/2018:  Creating Surfaces GameEx Logo
23:12:38.23  7/10/2018:  Creating Surface Unselected
23:12:38.24  7/10/2018:  Creating Surfaces Snaps
23:12:38.24  7/10/2018:  Creating Surfaces Menu and List Bars
23:12:38.28  7/10/2018:  Creating Fonts
23:12:38.29  7/10/2018:  Creating Game Font
23:12:38.33  7/10/2018:  Creating Game Font Faded
23:12:38.36  7/10/2018:  Creating Title Font
23:12:38.37  7/10/2018:  Restoring Title Font From Cache
23:12:38.45  7/10/2018:  Creating Font Black
23:12:38.47  7/10/2018:  Creating Font Black Small
23:12:38.51  7/10/2018:  Fonts Created Succesfully
23:12:38.52  7/10/2018:  Loading News Feed: http://www.gameex.net/gameexnews.xml
23:12:39.31  7/10/2018:  31MB Video Memory Used
23:12:39.32  7/10/2018:  Initial Emulator Load
23:12:39.35  7/10/2018:  Loading Custom Emulators
23:12:39.35  7/10/2018:  Loading Emulator 1: Nintendo NES
23:12:39.37  7/10/2018:  Checking if Steam enabled
23:12:39.38  7/10/2018:  Steam is installed correctly
23:12:39.38  7/10/2018:  Found Steam Base Install Folder: c:/program files (x86)/steam
23:12:39.38  7/10/2018:  Found Steam Base Install Folder: D:\\SteamLibrary
23:12:39.39  7/10/2018:  Found Steam Game: River City Ransom: Underground. AppID=422810. Location:C:\Program Files (x86)\Steam\steamapps\common\River City Ransom Underground
23:12:39.40  7/10/2018:  Found Steam Game: Sonic & All-Stars Racing Transformed Collection. AppID=212480. Location:D:\SteamLibrary\steamapps\common\Sonic & All-Stars Racing Transformed
23:12:39.40  7/10/2018:  Found Steam Game: Pinball Arcade. AppID=238260. Location:D:\SteamLibrary\steamapps\common\PinballArcade
23:12:39.40  7/10/2018:  Found Steam Game: Broforce. AppID=274190. Location:D:\SteamLibrary\steamapps\common\Broforce
23:12:39.41  7/10/2018:  Found Steam Game: 8BitBoy. AppID=296910. Location:D:\SteamLibrary\steamapps\common\8BitBoy
23:12:39.41  7/10/2018:  Found Steam games. Steam enabled.
23:12:39.42  7/10/2018:  Checking if Origin enabled
23:12:39.43  7/10/2018:  Cannot find origin executable
23:12:39.44  7/10/2018:  Checking if Uplay enabled
23:12:39.44  7/10/2018:  Cannot find UPlay executable
23:12:39.67  7/10/2018:  MAME CMD options: -nowindow -joy -skip_gameinfo -keyboardprovider dinput -noka
23:12:39.70  7/10/2018:  Initialising DirectInput for Gamepad support
23:12:39.75  7/10/2018:  Using Device Controller (XBOX 360 For Windows)
23:12:39.76  7/10/2018:  Loading Start Page
23:12:39.82  7/10/2018:  Initializing MCE Remote
23:12:39.82  7/10/2018:  Playing intro sound file
23:12:39.83  7/10/2018:  Initialization OK! Starting GameEx!
23:12:39.84  7/10/2018:  Testing Main Loop Once: Processing Frame
23:12:40.00  7/10/2018:  Testing Main Loop Once: Main Loop ran successfully
23:12:43.50  7/10/2018:  Attempting to load game list
23:12:43.61  7/10/2018:  Validating: Emulator_1: Custom Background: back-nintendo_nes.png
23:12:43.61  7/10/2018:  Validating: Emulator_1: Snap Path: E:\Artwork\Nintendo_NES\Snap
23:12:43.62  7/10/2018:  Validating: Emulator_1: Video Snap Path: E:\Artwork\Nintendo_NES\Video_MP4
23:12:43.62  7/10/2018:  Validating: Emulator_1: Database: [Console] Nintendo NES
23:12:43.62  7/10/2018:  Validating: Emulator_1: Title Snap Path: E:\Artwork\Nintendo_NES\Title
23:12:43.63  7/10/2018:  Validating: Emulator_1: Logo Snap Path: E:\Artwork\Nintendo_NES\Logos
23:12:43.63  7/10/2018:  Validating: Emulator_1: Box Art Path: E:\Artwork\Nintendo_NES\Box
23:12:43.63  7/10/2018:  Validating: Emulator_1: Cart Art Path: E:\Artwork\Nintendo_NES\Cart
23:12:43.64  7/10/2018:  Validating: Emulator_1: Manual Path: E:\Artwork\Nintendo_NES\Manual
23:12:43.88  7/10/2018:  Not Restoring Emulator Database From Cache: 1
23:12:45.39  7/10/2018:  Restoring Cached ICONS from File
23:12:48.03  7/10/2018:  Loading News Feed: http://www.1up.com/rss/latestUpdates?event=&platform=
23:12:54.83  7/10/2018:  Running: cmd.exe /c C: retroarch.exe -L "C:\Emulators\RetroArch\cores\fceumm_libretro.dll" "T:\Roms\Nintendo\Nintendo Entertainment System\Super Mario Bros. 3 (USA) (Rev A).7z" -c "C:\Emulators\RetroArch\retroarch.cfg" -f
23:12:55.10  7/10/2018:  Shutting down display
23:13:19.43  7/10/2018:  Writing Stats
23:13:19.46  7/10/2018:  Plugin: Game Exit
23:13:19.75  7/10/2018:  Plugin: Process Commands
23:13:19.75  7/10/2018:  Refreshing Keyboard
23:13:19.89  7/10/2018:  Initialising Audio
23:13:20.20  7/10/2018:  Restoring Window
23:13:20.21  7/10/2018:  Reinitializing Graphics System
23:13:20.37  7/10/2018:  initialized display
23:13:20.38  7/10/2018:  Display is running at: 1920x1080 32bit color, 60hz
23:13:20.75  7/10/2018:  Loading News Feed: http://www.1up.com/rss/latestUpdates?event=&platform=
23:13:21.50  7/10/2018:  Reloading Game Info Page
23:13:21.72  7/10/2018:  Returning to GameEx
23:13:26.93  7/10/2018:  Exiting GameEx!
23:13:26.94  7/10/2018:  Closing HideOS.exe
23:13:29.27  7/10/2018:  Disposing all videos
23:13:29.27  7/10/2018:  Deleting temporary Karaoke videos
23:13:29.28  7/10/2018:  Disposing Image List
23:13:29.28  7/10/2018:  Disposing Fonts
23:13:29.28  7/10/2018:  Disposing Surfaces
23:13:29.30  7/10/2018:  Saving Settings
23:13:29.30  7/10/2018:  Saving Settings
23:13:29.31  7/10/2018:  Shutting down Bass
23:13:29.36  7/10/2018:  Disposing Plugins
23:13:29.37  7/10/2018:  Disposing Plugins
23:13:29.37  7/10/2018:  Closing database connection
23:13:29.38  7/10/2018:  Checking for applications to Launch On Exit
23:13:29.39  7/10/2018:  Logging out of GameEx Online
23:13:30.02  7/10/2018:  Bye

 

 

Share this post


Link to post
Share on other sites

Hello and Good Morning/Afternoon/Evening! :D 

I hope all is going well for everyone in the GameEx family.  It's been a little while since I was last active, mostly due to life going a bit fast (switching jobs, remarried, school) - I've been getting more into the IT field, and now work in the IT department of a university here in Mississippi.  

Anyway lol...

I came across this post, and saw something that may or may not help out, at least with the audio.

I was having a similar audio issue in the latest versions of GameEx.  I normally have a music playlist going outside of running a game.  After exiting a game and returning to GameEx, sometimes the music volume would be really low, to the point to where it sounds muffled....and there would be no menu sounds.  Exiting and restarting GameEx would fix this temporarily, until exiting another game where it would randomly occur again.  

When troubleshooting, there was something I noticed within the GameEx logs....when exiting a game and returning to the FE, this issue happened only when GameEx would "Initialize Audio".  When GameEx didn't initialize audio, the audio would work normally.  I reverted to an older, backed up version of GameEx as a work around.

I seen something in the logs that was posted by Adultery:

23:13:19.89  7/10/2018:  Initialising Audio

 

I hope any of this information helps :). 

Share this post


Link to post
Share on other sites
On 7/11/2018 at 3:16 PM, thurmansevolution said:

 hope any of this information helps :). 

All information helps my man, even if not immediately. Thanks for the share.

Share this post


Link to post
Share on other sites

The audio issues are fixed in the latest release. Now available.

Im not sure about the gamepad issues right now. Any more information would be helpful.

Share this post


Link to post
Share on other sites

I meant to update you on this, mine was a faulty USB port. I replaced the hub and I'm not having an issue any longer. Was watching it in Function Logger and my key presses are all processing fine.

I'll holler back about the audio after I play around in there some.

Share this post


Link to post
Share on other sites

Should have a chance to try out the audio fix tomorrow.

Share this post


Link to post
Share on other sites

Hi Tom,

Woo-hoo. 15.35 does appear to fix the audio re-init problem.   Thanks for that.   

With that said, I have another issues that I will post in a separate thread that are still preventing me from using the latest build.  It has some relation to the game controller issue and might provide some more info toward fixing that.

Dave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×