Jump to content
SpesoftPinballXConvert-It
Calbarn04

PLEASE HELP pinball x back glass video won't show up [RESOLVED]

Recommended Posts

I have the play field and DMD videos showing up on the right screens but the back glass won't. I've gone through and assigned the back glass to every display option but none work. Please help me!!!

Share this post


Link to post
Share on other sites

Can you help the team by attaching copies of your pinballx.ini and log.txt files? 

You might want to give more details such as whether or not you are referring to the backglass videos outside of the game or while in a game. If in a game, what simulator or emulator.

Share this post


Link to post
Share on other sites

are you naming the tables and b2s files the same, in some instances the tables and b2s have to be the same name as the rom.

do you mean BG is not showing up during table selection or gameplay, does the backglass show up outside of PBX?

Share this post


Link to post
Share on other sites

It is the pinballx back glass videos. So not in game. I'm currently not at home but as soon as I am I will post my pinballx.ini and log.txt files. I am also not usind directb2s in the front end. Sorry for not giving detail in my original post.

Share this post


Link to post
Share on other sites

whats showing up, is the screen black, also post your xml file.

and are these vpx videos?

Share this post


Link to post
Share on other sites

The playfield is on the correct monitor and the black glass shows under the dmd. the dmd is on the correct monitor. I'm not using directb2s in pinball just videos and where will I find the xml you are wanting

Share this post


Link to post
Share on other sites

so you have a 3 screen setup?

does everything show up correctly after you launch a table?

what does your graphics display setup look like, and what numbers show up when you click on identify?

xml's are found in the database folder.

Share this post


Link to post
Share on other sites

yes I have a 3 screen setup. everything shows up correctly when I launch a table. when I identify it shows up as playfield=1 backglass=2 and dmd=3. what do you mean by graphics display setup. In the databases folder there are 7 folders that have an xml in each do you want all of them or just the ones for the emulators I use for example future pinball and visual pinball.

Share this post


Link to post
Share on other sites

attach the one for visual pinball will suffice.

unless you didnt change this back after testing.

you have the dmd and backglass set to monitor 1

[BackGlass]
monitor=1
x=0
y=-
width=1920
height=720
AutoPositionB2S=True
UseB2S=False
[DMD]
Enabled=True
monitor=1
x=500
y=1150
width=900
height=300
AutoPositionPinMAME=True
[FileSystem]

 

Share this post


Link to post
Share on other sites

my setup

[Display]
Monitor=0
rotate=270
Windowed=False
WindowWidth=480
WindowHeight=720
WindowX=0
WindowY=65
PlayFieldBrightness=210
WheelTextColor=ffffffff
WheelTextOutlineColor=ff000000
InfoTextColor=ffffffff
InfoTextOutlineColor=ff000000
FilterTextColor=ffffffff
FilterTextOutlineColor=ff000000
MenuColor=ffffa500
ShowExitImageFor=2
FullScreenWindowed=False
[BackGlass]
monitor=1
x=0
y=0
width=1360
height=768
AutoPositionB2S=False
[DMD]
Enabled=True
monitor=2
x=40
y=215
width=1840
height=597
AutoPositionPinMAME=False
[FileSystem]

ScreenRes.txt file

1920
1080
1360
768
2
0
0
1851
602
1395
211
0

image.png.0d8f8f65222dbcadd180b86b852be915.png

 

Share this post


Link to post
Share on other sites

Basically i have the backglass showing on the same screen as the dmd but no matter what i change the backglass monitor to it dosnt show up.

Share this post


Link to post
Share on other sites
Have you tried making any changes according to my PinballX.ini

Share this post


Link to post
Share on other sites

your video config may be hosed, try unplugging the dmd monitor and see if the the backglass diverts to the 2nd screen.

 

Another method is to unplug all, then plug in your playfield, the boot.  Then shutdown, plug in your backglass then reboot, then finally do the same with the dmd.

lastly try this.

 

https://support.displaylink.com/knowledgebase/articles/736116-windows-display-properties-identify-numbers-are

 

  • Like 1

Share this post


Link to post
Share on other sites

When I unplug the DMD monitor the back glass goes to the correct screen when I plug it back in everything is on the correct monitor. 

Share this post


Link to post
Share on other sites

 

[BACKGLASS]
monitor=1    <<< you have them set to the same number In pinballX settings
x=0
y=-
width=1920
height=720
AutoPositionB2S=True
UseB2S=False
[DMD]
Enabled=True
monitor=1    <<< you have them set to the same number In pinballX settings

Share this post


Link to post
Share on other sites

I know backglass and dmd are set to the same monitor because no matter what I change the backglass to it doesn't show up on the screen I want it to unless I unplug the dmd monitor than plug it back in.

Share this post


Link to post
Share on other sites

rblack97 I think your idea of the video config being hosed (have no idea what that means) could be correct as thebackglass moves to the correct screen when I unplug the dmd monitor. when I plug it back in everything is correct.

Share this post


Link to post
Share on other sites

so in the midst of all of this lovely configuration the PC gets confused on what needs to go where, so in the registry it just keeps adding new configs and not getting rid of the old ones.  so you'res is overlapping somewhere.

the link i pointed you to has a regedit file that will clean that up, then you can start fresh, by plugging each screen in and letting the PC reconfigure the identities.

47 minutes ago, Calbarn04 said:

rblack97 I think your idea of the video config being hosed (have no idea what that means) could be correct as thebackglass moves to the correct screen when I unplug the dmd monitor. when I plug it back in everything is correct.

Im assuming since you're saying the above your good to go now?  Is everything showing on the right screen now?

Share this post


Link to post
Share on other sites

Thank you so very much for helping me it fixed and it all works properly now. I really appreciate your help.

Share this post


Link to post
Share on other sites
23 hours ago, rablack97 said:

your video config may be hosed, try unplugging the dmd monitor and see if the the backglass diverts to the 2nd screen.

 

Another method is to unplug all, then plug in your playfield, the boot.  Then shutdown, plug in your backglass then reboot, then finally do the same with the dmd.

lastly try this.

 

https://support.displaylink.com/knowledgebase/articles/736116-windows-display-properties-identify-numbers-are

 

@rablack97 +1 for this.... was about to mention this next but you beat me to it :-)

 

@Calbarn04 if all ok please maRK as [RESOLVED]

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×