jbam

Help getting MAME screensaver 0.94 to work please

Recommended Posts

jbam    0

I recently downloaded the latest version of MAME screensaver on a Windows 10 64 bit computer on which I am running MAME 0.185.  My romset matches the version of MAME and seems to work quite well.  However, when I try to preview it or when it attempts to run, I just get a flash on my screen and then it returns to my wallpaper.  I changed the settings to pint to my mame64.exe file and to point to the roms.  Can someone out there please point me in the right direction?  Thanks!!

Share this post


Link to post
Share on other sites
RedDog    254

Hi jbam,

Did you remember to create the MAME game list in the screensaver settings? If you do not generate the list, the screensaver will just flash at you when you attempt to preview it.

  • Like 1

Share this post


Link to post
Share on other sites
jbam    0

Hi RedDog,

Thanks!!  That must be the issue.  I should have mentioned that I am very new to MAME and my frontend takes care of filtering working roms for me.  So, I seem to have a few choices like ROMLister and ROMCenter.  Would you recommend either of those?  Also, once I compile my MAME game list, do I need to do anything else to get that to sync with the sceensaver?

Thanks again,

jbam

 

 

Share this post


Link to post
Share on other sites
RedDog    254

Sorry, but I am not familiar with ROMLister or ROMCenter. Unless someone else knowledgeable chimes in, the best I can suggest is to look around for reviews or just tinker around with both and see which works for you.

As far as the screen saver, I think you may have missed what I was saying. You will need to enter stuff in the Settings tab of the screen saver (see below):

2017-06-05 19_29_21-Program Managerb.png

Once your settings are entered, press the button at the bottom that I highlighted. This will generate a game list that the screensaver will use to choose games to display. Keep in mind that this list is generated based on the Mame executable and roms that you enter above...so if you ever decide to make changes to Mame such as recompiling the executable, changing folders, updating rom versions, etc, you would want to update the Settings and generate the list again.

  • Like 1

Share this post


Link to post
Share on other sites
jbam    0

Thanks again!  I did misunderstand you and while I had entered all of he settings, I had forgotten to create the games list.  So, I went back and successfully did that.  However, I am still having the exact same problem.  I just get a brief flash on the screen when I either preview or use the MAME screensaver,

Any other ideas as to what the problem could be?

jbam

Share this post


Link to post
Share on other sites
RedDog    254

I was able to get mine working from the start, but I am on Windows 7 64 bit.

Mame must be working outside the screen saver, but you said that your Mame executable and rom set were the same version and that it was working well. You said you were a bit new to Mame, but you seam to know the importance of versions matching up, so I am going to assume you are good there.  :)

Recheck the Mame Screensaver Configuration (ie the Settings) again in case there is a typo and recreate the game list. Be sure to click the Game List Filter/Management button and doublecheck that "Only Fully Working" is checked (on the off chance that your test pulled a non-working game).

Also, I assume you have .net framework 2 installed as it is a requirement for the screen saver. If you have later versions installed, I believe you should already have it. If you are not sure, this site gives a pretty good walk-through on checking if you have it already.

If you still cannot get it to work, please post a screenshot of your Mame Screensaver Configuration. Then we can flag down the dev and see if he has a suggestion.

 

Share this post


Link to post
Share on other sites
jbam    0

Thanks for sticking with me on this.  So, I double-checked the settings and recreated the Games list.  I also double checked that only fully working games was selected and checked that I had Net Framework 2.0 installed.   I restarted my machine as well. 

 

I am including a screenshot of my settings.  Any thoughts would be greatly appreciated.  Thanks.Mame_screensaver_settings.PNG.063d6d9c80e008b50fee9645b88efd4a.PNG

Share this post


Link to post
Share on other sites
RedDog    254

@jbam Sounds like you got the imprtant stuff covered.

@Tom Speirs Hey Tom, do you have any suggestions for jbam?   :)

 

Share this post


Link to post
Share on other sites
jbam    0

Just thought I would check back to see if anyone had any insight on getting the MAME Screensaver to work.  Thanks!

Share this post


Link to post
Share on other sites
RedDog    254

Hey jbam,

I know that Tom is aware of this thread. Hang in there.   :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now