Necromancyr

bug
[RESOLVED] GameEx won't start in windowed mode (Windows 7)

11 posts in this topic

So, in trying to get CPWizard to work I think I discovered a bug in GameEx.  In short, it won't start in windowed mode.  And it doesn't seem to want to set a resolution. 

The windowed mode I've tested more extensively.  Basically, if I go into the SetupWizard OR manually change my .ini so it should start windowed mode, and then start GameEx, it starts up fullscreen as usual and changes the setting in the ini back to fullscreen mode.  I've confirmed the change is made in the ini and it's running GameEx that switches it back.  This happens with or without 'use fullscreen window' on or off. 

Not really certain what's going on.  I can upload a log if desired, but it doesn't show much - just normal loading.  Let me know if you'd like me to do a certain series of things to generate a useful log - can do that as well.

Share this post


Link to post
Share on other sites

Generally a good idea to provide copies of your gameex.ini and log.txt files when reporting an issue, even if there is nothing apparent in the log.

Share this post


Link to post
Share on other sites

Agree.  Part of my question was what would be the best way to provide that log and the setup before it so it wasn't just a log and config showing it running in fullscreen.  However, log and ini attached.

log.txt

GameEx.ini

Share this post


Link to post
Share on other sites

Does the reported behavior present itself when you do not have CPWizard enabled?

Share this post


Link to post
Share on other sites

Yes. 

 

Does CPViewer modify the GameEx.ini in anyway?  Because that's being reverted to the original setting.

Share this post


Link to post
Share on other sites

Some additional logs.   A pre-run and a post-run ini are attached.  Only differences (using diffchecker.com) are:

  • timesruncount=16 --> timesruncount=17
  • startpagethumbscount=4 --> startpagethumbscount=5
  • windowed=True --> windowed=False

Not certain what's happening or causing it.  The log, where I just ran GameEx and immediately exited, is attached also.

GameEx - Post.ini

GameEx - Pre.ini

log.txt

Share this post


Link to post
Share on other sites

It is (and was above for the logs).  It's set as disabled.  I reset it and tried it both set to 'Windowed' and 'Disabled' again, no change.  I confirmed that it's set as disabled in my ini as well (given it's the last line), so that seems to be getting set by the Settings Wizard.

Share this post


Link to post
Share on other sites

What resolution are you running at?

It may be that its set in the theme perhaps?

Share this post


Link to post
Share on other sites

I found it. its the show window controls / allow window resize. If that is off it forces full screen.

1 person likes this

Share this post


Link to post
Share on other sites

And, that is it!  Definitely recommend adding something to the tooltip there because I NEVER would have guessed it otherwise. 

Unfortunately, this didn't actually help with CPWizard - still being flaky on when it displays and when it doesn't.  With a windowed setup it's fine, but with either fullscreen option it seems to show semi-randomly.  Going to have to test more and discuss with HeadKaze.

 

Thank you again for the help!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.