Jump to content
SpesoftPinballXConvert-It
Lizard

[RESOLVED] "Version expired. Please download new version"

Recommended Posts

God damn it - have struggled with PinballX for days - and when I finally found a fix for it, then this happens.

Share this post


Link to post
Share on other sites

Hang tight, I'm sure Tom will respond to this.  Like many of us, he is enjoying the holiday.

  • Like 1

Share this post


Link to post
Share on other sites

Yes, the firewall block isn't working for me.  Not sure how to get around it.  Just started having the issue around the same time as the rest of you posting today.  Playing offline is my only way to make PinballX work, and Steam needs internet.

Share this post


Link to post
Share on other sites

Enable a firewall rule to block PinballX from talking to the internet so we can play Pinball without getting the "Version Expired. Please Download New Version." error for those of us that already are running the newest version.  Note: This is successfully tested on my Win7 Pinball cab, but I also tested the commands on Win10 and it does create/delete the rule there successfully too.

Copy and paste the following command in a command prompt window if you don't want to mess with the Windows Firewall GUI.  (Start > Run > CMD)

-Please note, if your path to the executable is different, you will need to edit the path to the .exe.  Also, some may be using PinballXLite.exe instead.  Make the adjustments as needed.

netsh advfirewall firewall add rule name="Block PinballX" dir=out action=block program="c:\pinballx\pinballx.exe" enable=yes

Here's the command to delete the rule that was just created; when a fix as been rolled out and you want to return to normal.  Again, copy and paste the following command in a command prompt window.

netsh advfirewall firewall delete rule name="Block PinballX" dir=out

I attached the commands above in the form of batch files as well, if someone would rather use that.  See attachments.

Happy New Year everyone!  Now go play some Pinball! :)
Smoke.007

Unblock PinballX.bat

Block PinballX.bat

Edited by Smoke.007
insert the code as code, added batch files, added comment that user's path could be different or alt PinballXLite.exe could be used
  • Like 1

Share this post


Link to post
Share on other sites

Same issue for me too; it'll get fixed soon enough, I have no doubt. In the meantime, I can just unplug the network cable... :) 

Share this post


Link to post
Share on other sites
1 hour ago, hendrix1 said:

which exact .exe in the pinballx folder? not working for me

PinballX which is marked Application 971KB if you have Details selected in File Explorer

Share this post


Link to post
Share on other sites

Ditto on this issue today, seems like a systemic problem, went to show a friend the cool software and it bombs. 

Share this post


Link to post
Share on other sites

Hi,

this messages appears on my both systems, one running with 2.27 the other with 2.28.

Please get us a fix.

Thanks, Christian.

Share this post


Link to post
Share on other sites

I assume "PinballX.exe" is not working for you, but it could be "PinballXLite.exe" if that is what you use

 

64466733.jpg

Share this post


Link to post
Share on other sites
3 hours ago, Smoke.007 said:

Enable a firewall rule to block PinballX from talking to the internet so we can play Pinball without getting the "Version Expired. Please Download New Version." error for those of us that already are running the newest version.  Note: This is successfully tested on my Win7 Pinball cab, but I also tested the commands on Win10 and it does create/delete the rule there successfully too.

Copy and paste the following command in a command prompt window if you don't want to mess with the Windows Firewall GUI.  (Start > Run > CMD)


netsh advfirewall firewall add rule name="Block PinballX" dir=out action=block program="c:\pinballx\pinballx.exe" enable=yes

Here's the command to delete the rule that was just created; when a fix as been rolled out and you want to return to normal.  Again, copy and paste the following command in a command prompt window.


netsh advfirewall firewall delete rule name="Block PinballX" dir=out

I attached the commands above in the form of batch files as well, if someone would rather use that.  See attachments.

Happy New Year everyone!  Now go play some Pinball! :)
Smoke.007

Unblock PinballX.bat

Block PinballX.bat

Don't forget that some users will need to edit the location of PBX as we don't all have it living in the same place.

 

  • Like 1

Share this post


Link to post
Share on other sites

I'm also having this problem I have just upgraded to newest version and get the message 

 

"Version expired. Please download new version"

Share this post


Link to post
Share on other sites

I am having the same issue which sucks as I just setup 8 tables and media in the manager and installed  a VPin plunger and spent a good part of the day setting it up on my only day off this week. Totally grateful for the support and the program and all that Tom and the crew does but damn I am bummed.  Fingers crossed the firewall trick works.

Share this post


Link to post
Share on other sites
1 hour ago, gtxjoe said:

I assume "PinballX.exe" is not working for you, but it could be "PinballXLite.exe" if that is what you use

Thank you for the reminder.  I updated my workaround/fix post above with that info.

Share this post


Link to post
Share on other sites

Smoke.007,

Thanks for the commands to use windows firewall to block and unblock pinballx programs from connecting to the internet.  It is working well for me.  I too was trying to show a fried my visual pinball setup when it I got the expiration dialog box.  I am sure it will get fixed soon.  Thanks again for the work around.

 

Steve

Share this post


Link to post
Share on other sites

How-To: Fix PinballX "expired" error

KB013 - How-To: Fix the PinballX "expired" error

The problem occurs as a result of an uppercase / lowercase typo within the PinballX (pinballx.ini) configuration file. It’s a quick and easy fix.

  • Close PinballX if it's open
  • Click 'Windows Explorer' icon on taskbar
  • Double click 'Local Disk (C:)'
  • Double click 'PinballX' folder
  • Double click 'Config' folder
  • Double click the 'PinballX' file
  • Scroll all the way to the bottom
  • Change the UPPERCASE letter "P" to a lowercase letter "p" on the following lines:

[Partner]
DontDisplayUpdateMessage=True
Code=VPCabs1012

If you also have these lines change the "P" to lowercase here too:

[Parnter]
DontDisplayUpdateMessage=True
Code=VPCabs1012

  • Click the [X] to close window and SAVE when prompted
  • Close all open windows and restart PInballX
  • Like 5

Share this post


Link to post
Share on other sites

Chaser,

I added the following lines with lowercase "p"  to my pinballx.ini and it resolved the issue.  I no longer need to block pinballx.exe from connecting to the internet.

[Partner]
DontDisplayUpdateMessage=True
Code=VpCabs1012
 

Thanks

 

  • Like 4

Share this post


Link to post
Share on other sites

I have the .ini file in the location that you referenced, but strangely, I don't have that string of code listed anywhere.  Any reason what that code is, and why some of us may or may not have it?  I'm using the latest version of PinballX.

 

Thanks,

Jason

Share this post


Link to post
Share on other sites

I also did not have a [Partner] section in my C:\PinballX\Config\PinballX.ini file, but adding the following to the end of the ini file and saving it did fix PinballX without the need to block it via Windows Firewall.  Wierd.

[Partner]
DontDisplayUpdateMessage=True
Code=VpCabs1012

Thanks Chaser for the info!

  • Like 2

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×