Jump to content
SpesoftPinballXConvert-It
Rochabian

Custom Background is missing / black

Recommended Posts

I've made a video to show the problem i encounter. See Below. I explain.

My game list view display artwork background for each game. I've set up a custom background wich is the gamecube image that appears when "Nintendo Gamecube" is selected. The same image is set as "no snap" image.

When i enter in the Gamecube Game list, game artwork is displayed in background ( i think it's searching matching file in this order : background->Box->snap). But when a game has no artwork and gameex can't find a suitable one, the background is black as  you can see in the video. I want to display the "custom background image" when Gameex doesn't find a suitable artwork. Is it possible or is it a non implemented feature ?

Better than words, see the video below, the problem appears when i go above the most played games list, when there is an empty line ->black background, and it's the same if it can't find a suitable artwork :

Black_Background_Problem.mkv

EDIT : Adultery has answered he can reproduce the problem so it appears it's a bug.

Can it be fixed in a future update ?

Thanks for your work

Share this post


Link to post
Share on other sites

Have you tried messing around with DisplaySettings>BackgroundMode?

 

Share this post


Link to post
Share on other sites

The problem is well resumed in the settings : you have three choices :

1 :Use Background Image

2: Use Black Background

3: Use Game/Item Image

So when a game/Item image is not found, it should (in my opinion ) use background image. Instead of that, it display black background.

My theme is set to use background/snap. changing the theme settings does'nt resolve the problem.

I have to try to change the Background Mode as suggested, perhaps it changes something. I'll let you know

Thanks

 

Share this post


Link to post
Share on other sites

Switching from "Use Background Image" to  "Use Game/Item" Image doesn't change anything

 

Here is my Gameex.ini if needed

GameEx.ini

Share this post


Link to post
Share on other sites

Another strange thing :

When i'm on the list of emulators like on the video above,displaying my custom background for each emulator, Gameex play random game video of the emulator selected.

Thoses videos doesn't have sound, but if i enter the gamelist, videos have sound.

Isn't sound allowed for "Image 2" ?

Can you confirm this too Adultery ?

Thanks

Share this post


Link to post
Share on other sites

I believe sound is only allowed for Image1.

Share this post


Link to post
Share on other sites

Ok so can a test be implemented in Gameex ?

For example IF Image 1 is a picture (no sound ) THEN Image 2 is sound enabled

or IF Image 1 is a movie (with sound) THEN Image 2 has sound disabled

I'm not a programmer so i can't say if it's hard or not to add this In Gameex

Perhaps just a setting to enable/disable Image 2 sound in the setup Wizard can be easier.

 

Share this post


Link to post
Share on other sites

I may seem a lil stupid here and i'll take it, but obviously you can't have sound enabled on two sources. Because you'll have two tracks playing over eachother. May i suggest looking into your hardware and see what is capable.

Share this post


Link to post
Share on other sites

Hi.

I've only browsed over this. Unless its a new bug form me implementing the wheel this can happen if you have specified background images for a system. Otherwise does changing view help?

Share this post


Link to post
Share on other sites

Yes i use custom background as you can see in the video.

Is it possible to display this custom background when no game arts are found to display on background instead of a black screen ?

In fact , the custom background can be displayed as a "no snap" image

EDIT : I've found a workaround : if i change the view to display snap/video in background instead of "background art", then when no snap is found, it displays the "no snap" image, wich is set like my custom background. But with this method i can't see the background arts....

 

Share this post


Link to post
Share on other sites

Ok thanks tom.

And what about the sound allowed in image 2 if image 1 is a picture ?

Is it possible ?

Because when you use system background (a picture) and when gameex picks up random game video for that system,  there is no sound.

Or is it a bug from the random video pick up?

( In my video, when i browse the systems, videos shown on the right (wich are randomly chosen by gameex) doesn't have sound, but when i'm in the gamelist they have sound)

Share this post


Link to post
Share on other sites

Anything is possible but all this is kind of by design right now. So I would not class it as a bug.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...