Jump to content
SpesoftPinballXConvert-It
time299

[APP] NukeLauncher - NukePA for (The Pinball Arcade)

Recommended Posts

Hey All

I have beating my head against a wall for weeks trying to straighten out the screen rotation issue, only to figure out today that my development system (A laptop with an Intel and Nvidia video card) was causing my issues, I think.

I can't reliably test it with my setup. So I am going to release it as is and see if you all can confirm that it works for everyone except me. I know that this sounds weird but logic says it should work for you all.

So here is the link to the New NukeLauncher for Pinball Arcade - NukePA download page

http://www.nukelauncher.com/item.asp?iid=31

WheelPA.gif

BTW: I am taking my wife to a hotel for new years night to get away form the fireworks in my neighborhood. The sounds and explosions affect her severely since her brain surgery. (Like someone with PTSD or autism). We have a MRI this week as well as a blood test and a neurology apt and then starting another round of chemo, So I will not be available for the next few days to a week.

I know you all have been waiting and I wanted to get it to you ASAP.

Sorry I have not had time to make any real documentation. Maybe you all can help each other out with questions and maybe someone will write up some instruction, it works the same way as NukeLauncher for Pinball FX2.

Note 1: For screen rotation to work you must have iRotate or video driver that supports screen rotation using hotkeys Ctrl+Alt+ left/right/up/down and you must set "Rotate = 270" or 90 or 180 to turn it on. Also before you use NukePA the first time you must rotate your screen and then run your Pinball Arcade "PBAConfig" program to lock in your screen settings in Pinball Arcade then rotate your screen back to normal and then NukePA will handle the screen rotation.

Note 2: You may need to add the new table they just released. It's missing from my XML and my auto detection scripts. So if you are using the steam version you will need to manually add it to the proper location in your NukePA.ini under the variable PinballTables = and it needs to be in the proper spot just like you do for NukeLauncher for Pinball FX2.

Love you guys, and good luck, and happy New Year, and please donate. This was my biggest project to date and a massive time investment.

Talk to you all in a few days. Enjoy

Jeff / Time299

gift.png

  • Like 3

Share this post


Link to post
Share on other sites

Thanks for all the hard work on this.

Note: I don't use iRotate in the cab because it is just one more program with an installer/residing in your system tray, etc. I've used in the past the following:

Display.exe from here:

http://noeld.com/programs.asp?cat=misc#download

It is portable and command-line driven. Works just fine calling it in AutoHotkey scripts. Still requires video drivers capable of rotation, so this may not help with your test bed. The deal is that the software is offered as freeware and no EULA license is specified at all. You may just be able to incorporate it in your distribution although you probably want to contact the developer and make absolutely sure.

rockyrocket has since turned me on to Display changer II which is considerably more powerful and also free but there are definitely license restrictions in place:

http://12noon.com/?page_id=641

I hope that all goes well with treatment.

Share this post


Link to post
Share on other sites

Finally had time today to spend with the cab. Install and setup of NukePA is no problem once you know your way around with NukeFX.

Sadly I can't seem to get it to work! There must be still something wrong with the the rotation stuff.

my display default landscape setup is windows taskbar on the left, so use irotate for portrait mode at 90 degrees, which is Ctrl+Alt+left. when I set nukepa.ini to 90 the picture of pinballx interface is upside down and tpa wont start.

I think it might interfere with the PinballX rotation. In PinballX I had to set the rotation to 270, to display the same as with irotate at 90 (which is already weird).

no combination I tried worked. I always get a pinball arcade stopped working error. when I lauch it manually or with my ahk rotation script it works.

Is there a default tabel start mode for NukePA to test it without PinballX? I didn't find a command line for that.

Share this post


Link to post
Share on other sites

I just started playing with this today, it is all working for me except choosing table, I believe I just have to mess with the timing. Mpad did you run pinballarcade.cfg with your screen set the way you plan to play as Jeff mentioned?

Share this post


Link to post
Share on other sites

I had to move my pinball arcade folder out of common and place it as well as nuke files in its folder in x86\steam...as I continue to play with this timing in now getting to the table select screen and just start attack from Mars

Share this post


Link to post
Share on other sites

I just started playing with this today, it is all working for me except choosing table, I believe I just have to mess with the timing. Mpad did you run pinballarcade.cfg with your screen set the way you plan to play as Jeff mentioned?

yes, I have. have been using pinball arcade and VP parallel for a while now and theoretically it should work. problem is I don't know exactly which rotation setting NukePA really uses, because everthing crashes. as said it seems to be something different than my default irotate 90 deg setting, as after I launch with nukePA pinballx is upside down. or maybe it uses the driver+irotate+pinballx and I end up by 450 degrees rotation or something...

so it would be cool to have a default table to start without pinballx for troubleshooting, like the startlocation=14 in NukeFX. NUkePA requires a tablename to work.

I had to move my pinball arcade folder out of common and place it as well as nuke files in its folder in x86\steam...as I continue to play with this timing in now getting to the table select screen and just start attack from Mars

hmm... I hope there is another way than that, cause I want to keep it on the other harddrive. does steam update etc. still work after you move it?

edit: I have the PA app installed in G:\SteamLibrary\SteamApps\common\PinballArcade and NukePA is in the default steam folder C:\Program Files (x86)\Steam

Share this post


Link to post
Share on other sites

The system I use is no longer online which I think may also be my problem. My PBA still advertises the window with Addams family kickstarter, that seems to be where...I might be losing a button press or something.

I use 270 rotation and before I moved my nuke files my pbx was also coming back upside down and it wasn't loading PBA at all.

I moved my files because of a message nuke launcher gave requesting me to do so. At first my nuke files were outside the PBA folder in x86\steam now that I moved them in steam\pinball arcade it loads but I still can't get it to pick any other tables.

Share this post


Link to post
Share on other sites

I'll definitely wait befor I move my PA folder.

270 didn't work for me...

just to rule it out: It should work with a German keyboard and german Windows? Maybe different keycodes?

Share this post


Link to post
Share on other sites

edit: I have the PA app installed in G:\SteamLibrary\SteamApps\common\PinballArcade and NukePA is in the default steam folder C:\Program Files (x86)\Steam

I had the same file placement, instead of moving your PBA folder did you try putting nuke files in the PBA folder?

Share this post


Link to post
Share on other sites
edit: I have the PA app installed in G:\SteamLibrary\SteamApps\common\PinballArcade and NukePA is in the default steam folder C:\Program Files (x86)\Steam[\quote]

I had the same file placement, instead of moving your PBA folder did you try putting nuke files in the PBA folder?

Share this post


Link to post
Share on other sites

Hey Guys

Don't move anything from were it was!

If you are using the Steam version your NukePA files should be located in the main steam folder where steam.exe is like shown below.

Make sure to right click and set to run as administrator just like the Pinball FX2 version.
steam_file_location.png

If you place your files here NukePA will auto detect that you are using Steam and will automatically know to use the proper command line for Steam. This is how the game will be launched - "Steam.exe -applaunch 238260"

Jeff / Time299

Share this post


Link to post
Share on other sites

When I had mine in there pbx would go to a black screen then go right back to the wheel...when I lived them in the PBA file it loads pinball arcade

Share this post


Link to post
Share on other sites

If it dose not work from the Steam folder then there is some other reason, like permissions or path in PinballX.

Mine is setup in the path shown above and works perfectly.

I have tested both Steam and Non Steam versions and it works both ways.

Share this post


Link to post
Share on other sites

Hey All

I am starting to write some documentation and will post it as I progress. For now I have just added links to several Pinball Arcade XML files.
So if you own season 1- 2 or season 1-2-3 you can just download that XML and not have to modify the one that comes with NukePA with all tables in it.

http://www.nukelauncher.com/item.asp?iid=33

Share this post


Link to post
Share on other sites

when i run nukepa i get this message and thats it. can anyone help

Share this post


Link to post
Share on other sites

I got that same message but don't get it when I launch directly from PBX it seems It can't run by itself

Share this post


Link to post
Share on other sites

i tryed running from PBX and got the same message it dont seem to work.

Share this post


Link to post
Share on other sites

When you try from a command line are you running the command line as administrator?

Are you guys passing the table name in Quotes?

Command Line Example:

NukePA_CommandLine.png

It sounds like you guys are not putting in the quotes around the [TABLEFILE] variable, see below this is how your PinballX.ini should look.

PinballX Example:

[System_2]Name=Pinball ArcadeEnabled=TrueWorkingPath=C:\Program Files (x86)\SteamTablePath=Executable=NukePA.exeParameters="[TABLEFILE]"SystemType=0LaunchBeforeEnabled=False

Share this post


Link to post
Share on other sites

hey Jeff, thought you wanted to take some days off :)

good news is, when I run NukePA standalone with tablename in comand line it works. I have to set rotation in NukePA to 270 to get the same orientation I get when I set Irotate to 90??? same for me with the pinballX internal rotation, the I have to set to 270 too. someone mixed up left and right arrow? whatever!

so basically it works.

I tried to start with pinballX - no chance. my pinballX config looks exactly like yours, but no luck. I get the same windows Pinball Arcade.exe stopped working bla error like when Pinball Arcade gets a display setup that is not defined in the PA config tool.

Did you test with Pinball X rotated? its in the first two lines of the PinballX config:

[Display]
Monitor=0
rotate=270

So I am 99% sure NukePA gets a wrong rotation and that it is relatad to the screen being already rotated by PinballX. but when I set to 0 it still wont work...straaange.

BTW: Great Media Pack!!! allthough some wheel images could be more high res if you stand in front of a 40" screen :-)

the still images for digital segment tables like black hole show almost like full orange on my setup. I think the grey backgroung has to go. will do a test...

Share this post


Link to post
Share on other sites

I have run the config tool with my screen rotated first and it saves the correct resolution. Then change the screen back after closing, then launch pbx, it works...still won't select table.

Share this post


Link to post
Share on other sites

I have run the config tool with my screen rotated first and it saves the correct resolution. Then change the screen back after closing, then launch pbx, it works...still won't select table.

I can 1000% confirm I did the same thing. It launches, rotates and perfectly selects the table when I start NukePa by command line.

with PinballX -Pinball Arcade crashes. Just noticed the error message is displayed in the correct orientation, so that seemed to work. but when I close the error with task manager and go back to pinballx the interface is rotated 90 deg to the right :P

so now I am 100% sure it messes with the internal PinballX rotation engine.

tip: maybe ask tom how it works and if it can be used for nukepa. so I can get rid of irotate.

Share this post


Link to post
Share on other sites

how to u get rid of the kick start advert for adams family at start.

  • Like 1

Share this post


Link to post
Share on other sites

mine rotates ok thro pinballx but just wont select table it only select attact from mars all the time.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×