Jump to content


Photo
- - - - -

whats the deal with show desktop?


  • Please log in to reply
23 replies to this topic

#1 slipstream19

slipstream19

    Advanced Member

  • Member
  • PipPipPipPip
  • 230 posts

Posted 06 April 2007 - 01:50 AM

Possible solution to everybody's "game works fine out of gameex, but in gameex only sound plays" issues..... setup GameEx to have the "show desktop" set to ON by default instead of OFF.. Then when people become more familiar with the inner workings of GameEx, they can go back and set it to OFF.
-------------------------------------

whats the deal with show desktop. whats the good things about having it on "off"

can someon give som insight into the "show desktop" matter?
dont really get it.

#2 scurvy

scurvy

    Member

  • Member
  • PipPipPip
  • 153 posts

Posted 06 April 2007 - 04:11 AM

wow thanks man, fixed my problem. was gonna post on that question soon

#3 Nologic

Nologic

    GameEx God (Top Rank)

  • Banned
  • PipPipPipPipPipPipPip
  • 1541 posts
  • Gender:Not Telling

Posted 06 April 2007 - 04:15 AM

hmm I think while it may get more people up and running...I think more would comment on the fact that GameEx would then look less polished...the only real true solution to the issue is to some how get GameEx and OpenGL rendering Emu's to behave better together.

My thoughts tho...take them as you will. :)

#4 slipstream19

slipstream19

    Advanced Member

  • Member
  • PipPipPipPip
  • 230 posts

Posted 06 April 2007 - 08:16 AM

hmm I think while it may get more people up and running...I think more would comment on the fact that GameEx would then look less polished...the only real true solution to the issue is to some how get GameEx and OpenGL rendering Emu's to behave better together.

My thoughts tho...take them as you will. :)

----

aha ok

is there any list of what emus work with show desktop off?

i know pc games must have it of. but
take the project64 , showdesktop on or off?

#5 Nologic

Nologic

    GameEx God (Top Rank)

  • Banned
  • PipPipPipPipPipPipPip
  • 1541 posts
  • Gender:Not Telling

Posted 06 April 2007 - 08:25 AM

That depends greatly on which render you use....as it has OpenGL, D3D, and Glide render's available to it...D3D Hide the desktop, OpenGL show the desktop, Glide...no clue as I don't have a Voodoo card installed on this system...actually on any of my systems...but I do have a Voodoo2 8mb card & a Voodoo 3000 16mb card laying around....maybe I'll work on a listing...as well as find out if Glide requires the desktop to be shown or not.

#6 scurvy

scurvy

    Member

  • Member
  • PipPipPip
  • 153 posts

Posted 06 April 2007 - 02:27 PM

how does it make gameex look less polished? didnt notice any difference.. but now my other emulators actually launch from gameex

#7 Nologic

Nologic

    GameEx God (Top Rank)

  • Banned
  • PipPipPipPipPipPipPip
  • 1541 posts
  • Gender:Not Telling

Posted 06 April 2007 - 05:15 PM

Well I guess that all depends on how messy ones desktop is, and how fast ones system is.

On my main stay system the desktop is a mess, several scripts, icons, sticky notes, widgets, docks, IM's,....needless to say a bunch of stuff I don't want to see when I'm in a gaming session. :)

Now the HTPC...thats a different story...desktop is clean, no wallpaper (set to black color), taskbar is set to be completely transparent...so showing the desktop on it is a non issue.

#8 scurvy

scurvy

    Member

  • Member
  • PipPipPip
  • 153 posts

Posted 06 April 2007 - 06:44 PM

well you never actually see my desktop, it goes right from gameex to the full screen emulator (nes, snes n64) you have it windowed?

btw how do you make the taskbar transparent?

#9 Nologic

Nologic

    GameEx God (Top Rank)

  • Banned
  • PipPipPipPipPipPipPip
  • 1541 posts
  • Gender:Not Telling

Posted 06 April 2007 - 08:35 PM

No...basically depends if you are having to load a large file...ie mounting a CD image in Daemon Tools prior to launching the actual Emu.

as for the taskbar...there are several apps\ways. For doing it on the cheap I suggest Transparent TaskBar if you truly want to make it completely transparent...other wise you may wish to check out Glass2k (also free) which will make it nearly transparent but will add a few extra's that you won't find in Transparent TaskBar.

Basically fire up Transparent TaskBar set the taskbar to transparent right click on the slider select Exit...now should you find your self needing the taskbar to be visable simply hit your WinKey and the Start Menu will open up...browse to the application and start it again...and simply adjust your settings and exit it yet again.

#10 bkenobi

bkenobi

    GameEx God (Top Rank)

  • Elite Member
  • PipPipPipPipPipPipPip
  • 4876 posts
  • Location:Seattle, USA

Posted 06 April 2007 - 09:54 PM

So how did you eliminate all of the icons windows wants to put on the desktop (my computer, recycle bin, etc.)? I know some of this can be done with the instant sheller or with tweakui, but what did YOU do? :D

#11 Nologic

Nologic

    GameEx God (Top Rank)

  • Banned
  • PipPipPipPipPipPipPip
  • 1541 posts
  • Gender:Not Telling

Posted 06 April 2007 - 10:30 PM

Well first off I didn't have anything other than the Recycle Bin on the desktop to begin with...default stock Desktop.

If you have any other Shell icon's My Computer, My Documents,... those can be removed via the Desktop Display properties dialog:

Right Click the Desktop
Select Properties from the context menu
Click Desktop tab
Click Customize Desktop...
Deselect all Desktop Icons
Click below that branch on
Any non Shell icon's move else where like say the My Documents folder...

So really at this point all that should be left is the Recycle Bin this can be solved by a simple registry edit:

Press WinKey+R
Type regedit into the edit box of the Run dialog
Press OK
Click the left side (TreeView) of the Registry Editor on HKEY_CURRENT_USER to expand it
Click below that branch on SOFTWARE to expand it
Click below that branch on Microsoft to expand it
Click below that branch on Windows to expand it
Click below that branch on CurrentVersion to expand it
Click below that branch on Explorer to expand it
Click below that branch on HideDesktopIcons to expand it
Click below that branch on NewStartPanel to expand it or ClassicStartMenu if using the Clasic Start Menu
Right Click on the list view item {645FF040-5081-101B-9F08-00AA002F954E}
Select Modify from the context menu
Set the value in the edit box for Value data: to 1
Click the OK button
Close the Registry Editor
When back at the Desktop if the Recycle Bin is still there then:
Left Click once on the Desktop
Then press the F5 Keyboard key

Or you could just simply merge the attached REG file into your registry. :)

#12 Nologic

Nologic

    GameEx God (Top Rank)

  • Banned
  • PipPipPipPipPipPipPip
  • 1541 posts
  • Gender:Not Telling

Posted 06 April 2007 - 10:43 PM

Additionally for those ether scared of altering their registry or leery of merging REG files there is another alternative and thats to use Tweak UI.

Once installed simply start the application
Click Desktop on the left side TreeView
Then uncheck every option in the Selection Box on the right
Click the OK button and now your all done. :)

#13 headkaze

headkaze

    GameEx God (Top Rank)

  • GameEx Author
  • PipPipPipPipPipPipPip
  • 4632 posts
  • Gender:Male

Posted 06 April 2007 - 11:38 PM

There is an easier way to hide desktop icons, rightclick the desktop, select Arrange Icons By->Show Desktop Icons.

#14 Nologic

Nologic

    GameEx God (Top Rank)

  • Banned
  • PipPipPipPipPipPipPip
  • 1541 posts
  • Gender:Not Telling

Posted 07 April 2007 - 01:25 AM

Oh man...yeah just got to hate it when you get out classed. ;)

I'll go stand in the corner now, with my dunce hat on. :)

#15 scurvy

scurvy

    Member

  • Member
  • PipPipPip
  • 153 posts

Posted 07 April 2007 - 02:49 AM

ok so i dont get it. i have nes, snes and n64 emulators. the only one i can get to work is snes because it shows the option show desktop.. the other emulators dont show the option in the gameex setup. so snes launches games fine from gameex, but nes and n64 i just get a black screen when launching games. what am i missing here?

#16 scurvy

scurvy

    Member

  • Member
  • PipPipPip
  • 153 posts

Posted 08 April 2007 - 03:55 AM

so i cant really fix this problem, the only emulator i can get working 100% is mame.. my nes, snes, n64 only work about 50% of the time.. either working or just coming up with a black screen, i turned show desktop on for all the emulators.. any help?

#17 Adultery

Adultery

    GameEx Tweaker

  • Admin
  • PipPipPipPipPipPipPip
  • 7921 posts
  • Gender:Male
  • Location:Wisconsin
  • Interests:Heiney-kins???

Posted 08 April 2007 - 04:59 AM

So you do or don't have ShowDesktop= set to True for these emulators? (Advanced Config, Emulator xx, Page #3)

Adultery2.png
 

Adultery.png


#18 scurvy

scurvy

    Member

  • Member
  • PipPipPip
  • 153 posts

Posted 08 April 2007 - 05:12 AM

yes, i have show desktop set to YES for all of them

#19 bkenobi

bkenobi

    GameEx God (Top Rank)

  • Elite Member
  • PipPipPipPipPipPipPip
  • 4876 posts
  • Location:Seattle, USA

Posted 08 April 2007 - 04:47 PM

There is an easier way to hide desktop icons, rightclick the desktop, select Arrange Icons By->Show Desktop Icons.


OH HOLLY HELL!!! That is just too easy. Where is my dunce cap when I need it :angry:

#20 Adultery

Adultery

    GameEx Tweaker

  • Admin
  • PipPipPipPipPipPipPip
  • 7921 posts
  • Gender:Male
  • Location:Wisconsin
  • Interests:Heiney-kins???

Posted 08 April 2007 - 11:36 PM

so i cant really fix this problem, the only emulator i can get working 100% is mame.. my nes, snes, n64 only work about 50% of the time.. either working or just coming up with a black screen, i turned show desktop on for all the emulators.. any help?

Some emulators need to be set up ooutside of GameEx. PJ64 and ZSNES both require you to set them to launch in fullscreen either through the GUI or the emulator's .cfg or .ini file. This may possibly be your issue, so try and do aa little 'tweaking' and see what happens. :)

Adultery2.png
 

Adultery.png





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users