Sign in to follow this  
Followers 0
Chaos.Tiki

PlugInLaunch not saving settings

15 posts in this topic

In the GameEx start menu folder select the PLUGIN MANAGER. :)

Share this post


Link to post
Share on other sites

I did that, and when i clicked configure, it didn't do anything. Should I post this as a bug?

Share this post


Link to post
Share on other sites

Did you click the plugin and highlight it first? :)

Share this post


Link to post
Share on other sites

OK, here's my findings.

I can now get xpadder to launch in this plugin. However when I try to run Daemon Tools, the image will not mount to the drive. If I put the "Launch Before" and "Launch After" in GameEx, and I put the xpadder command line in the plugin, it works just fine. I have tried copying and pasting the cmd line that works in GameEx into the plugin INI, and I have tried tweaking things as I thought of things to try.

No matter, everything works now, and my SSF 0.12 Beta is functioning like a dream now. smile.gif

Thanks a million HK! biggrin.gif

I just tried to do a simlar thing with the daemon tools before/after - mount/unmount commandlines, but when I click on save in the PluginLauncher window, it does not save. The ini is also blank. I just updated to GameEx 12.70 and this is the first time I'm using PluginLaunch.

Share this post


Link to post
Share on other sites

Before we declare a possible bug, can you confirm that you have access rights to the folder that the .ini is saved to?

Also, I am moving this to the General forum where error reporting is preferred.

Share this post


Link to post
Share on other sites

Sure no problem. As for access rights, I have GameEx installed on my R drive at R:\Frontend\GameEx\ - so I should have full rights. I just checked my security permissions for R:\Frontend\GameEx\PLUGINS\PlugInLaunch\PlugInLaunch.ini - and have read/write permissions for it.

Share this post


Link to post
Share on other sites

Ruh roh! Lemmie have a look. Just a sec.

Share this post


Link to post
Share on other sites

Holly balls sacks. I can't believe I made such a rookie mistake! LOL!

Had to change:

comboEmulators.SelectedText()

To:

comboEmulators.SelectedItem.ToString()

I probably shoulda used a datatable instead, but oh well. :)

Fricking embarassing! LOL!!!!

So this works, I addressed that bug, added in the block that lists all emulators instead of the enabled ones, and fixed another bug lurking in there. I can see I have to perform some cleanup on this before I make it an official release, but here's a 100% functional version for you to use in the mean time.

Sorry for my n00b1ne$$!

Share this post


Link to post
Share on other sites

So the whole line in the table of plugins is colored (the line that contains the plugin you want to configure), as in highlighted and not checked, and then you hit configure? Its working just fine for me. :(

Share this post


Link to post
Share on other sites

Thanks Adultery, settings are saved now. :)

Share this post


Link to post
Share on other sites

I moved a few more posts that were in the [NEWS] GameEx 12.70 thread to this one as it appears that the issues are related.

Please report bug and error reports to their own topic and not in the [NEWS] or [RESOLVED] topics so that they will get the prompt notice they deserve.

Share this post


Link to post
Share on other sites

@Bigby: Meet me in chat. I'll see if I can isolate the problem.

Share this post


Link to post
Share on other sites

OK, I need more info on this. Do me a favor:

Overwrite your plugin with this one:

Then go to GameEx/Plugins/PlugInLaunch and post a copy of the log file for me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0