Sign in to follow this  
Followers 0
snarls

help needed with virtual cd emus

9 posts in this topic

Hi,

I used to have SSF working fine via gameex but it just magically stopped working in the last couple of days. It all started when I started trying out different themes. I checked the log and see nothing unusual. Though I think it's not loading the disc image via DT Lite as it used to, because SSF says "Drive door open" for the virtual drive. I switched back to Default - New theme and that didn't fix it. I'm running 12.68.

I'm getting increasingly frustrated with the tricky/unstable setup for games which require CD images via a virtual drive. What would cause a working SSF to stop loading discs via the gameex launcher if the config hadn't changed?? If I manually load a disc image in DT Lite and run SSF it works - and it used to from gameex. Ive scoured these forums but nothing works anymore (when trying to load an iso/bin etc) - whats the trick? Ive also never been able to get epsxe to work loading discs ever. Any definitive help on this would be greatly appreciated. Does anyone have a definitively working import for SSF & ePSXe?

thanks :)

P.S. It was "Blue Glass" that I selected when things stopped working with SSF (all the other non-image emus still work fine) it's a nice practical theme with large screenshot images but I have a feeling it may not be fully working? is that possible?

log.txt

ssfexport.ini

epsxeexport.ini

Share this post


Link to post
Share on other sites

We shouldn't be seeing a theme "breaking" an emulator functionality. Can you provide a copy of your gameex.ini file as well? Also, please download the latest GameEx install file direct from the site and install it that way to see if it resolves your issue with SSF.

Share this post


Link to post
Share on other sites

Looking at the two emulator ini's. I see you're using virtualdrive instead of Daemon Tools lite to mount the images. Recently I too tried to use virtualdrive, but had problems with certain cd image types not mounting. Maybe try using DTlite instead of virtual drive?

Share this post


Link to post
Share on other sites

I use DT Lite and GameEx integrated support for it. My command line looks like this:

ssf.exe [VIRTUALDRIVE]:\

Do you have DT Lite installed on your machine? Post your Saturn config?

Share this post


Link to post
Share on other sites

I do have DTLite on my machine and ssf and epsxe work outside of gameex if i manually load a cd image into DTLite and run those emus.

So how does this work does gameex use its own virtual cd when you use the [VIRTUALDRIVE]:\ and the other option uses LaunchBefore and LaunchAfter calling DTLite to mount and unmount cds? I'm still not sure what the difference between [VIRTUALDRIVE]:\ and [-VIRTUALDRIVE-] is and why some people put the 2nd token here without a space next to the exe as Ive seen in the forum?

For Saturn, I have .iso, .cdi, .bin with .cue, and .mdf with .mds files. I checked the cues and they seem to point to the right paths and all of these work outside of gameex.

@Adultery can you please post your LaunchBefore and LaunchAfter and I'll try that.

@Draco I'm not sure the theme broke things, but it was after I tried a few and then switched to "Blue Glass" that my cd based emus stopped working properly. Also a few other minor weird things started happening, like the additional info per game used to load up in a wider zoomed in notepad thing (easy to read), and now loads in a portrait style notepad zoomed out with smaller text. Also pdf manuals dont seem to load and last played & playcounts for games don't show up on the game page (it just says N/A) though the game plays do show up on the Statistics page? Any ideas? I have 12.68 installed already... Can themes change functionality or are they just graphic skins?

thanks everyone for your assistance and patience trying to help me fix my issues... :)

SSF.ini

GameEx.ini

Share this post


Link to post
Share on other sites

Looking at the two emulator ini's. I see you're using virtualdrive instead of Daemon Tools lite to mount the images. Recently I too tried to use virtualdrive, but had problems with certain cd image types not mounting. Maybe try using DTlite instead of virtual drive?

thanks Bigby. Maybe you are right, but what was confusing me is that my emu configs hadnt changed but they stopped loading the cds thru gameex after I changed the theme so those images used to work. Unless it's an intermittent thing? But if you think DTlite is more reliable I'll try that again, I first tried it when I first setup gameex some months ago, but had trouble getting it to work even though my paths were correct...?

Share this post


Link to post
Share on other sites

We shouldn't be seeing a theme "breaking" an emulator functionality. Can you provide a copy of your gameex.ini file as well? Also, please download the latest GameEx install file direct from the site and install it that way to see if it resolves your issue with SSF.

Another question, as I posted it, I had a look through my Gameex.ini and there was some weird (but probably innocuous) stuff in it which must be in the install, since I don't have an app called mad dog nor an mp3 of 4 non blondes - ;-) but I'm fairly certain those aren't my problems. I'm just not sure why they are in there?

Share this post


Link to post
Share on other sites

Those are in there for the demo setup and can be removed without any problems.

Share this post


Link to post
Share on other sites

So how does this work does gameex use its own virtual cd when you use the [VIRTUALDRIVE]:\ and the other option uses LaunchBefore and LaunchAfter calling DTLite to mount and unmount cds?

I don't use a LaunchBefore / LaunchAfter because [-VIRTUALDRIVE-] handles all that for me. ;)

[Emulator_21]

PlayMusic=False

CustomArtName2=Advertisement

BoxPath=F:\Emulators\SSF\Artwork\Box

RemoveBrackets=True

ReplaceUnder=False

TITLETEXT=Sega Saturn

CustomArtName1=Box (Back)

ImageNotFound=F:\Images\no_img.png

PCGame=False

STARTPAGENAME=SEGA Saturn

CartPath=F:\Emulators\SSF\Artwork\CD

Info=Sega Saturn emulator

WorkingPath=F:\Emulators\SSF

Capitals=False

CustomArtPath1=F:\Emulators\SSF\Artwork\BoxBack

TitlePath=F:\Emulators\SSF\Artwork\Title

Emulator=SSF

Command=ssf.exe [VIRTUALDRIVE]:\

SnapPath=F:\Emulators\SSF\Artwork\Snap

DownloadUrl=http://www.gamesdbase.com/setupwizard/emulators/download/SSF.7z

PlayInScreenSaver=False

Enabled=True

RequiredFiles=Bios - SEGA_101.BIN and stv110.bin (512kb each)

SelectionMusicFolder=C:\Artwork\EmuMusic

ManualPath=F:\Emulators\SSF\Artwork\Manual

LaunchBefore=

LaunchAfter=

MapKeys=True

System=Sega Saturn

configFile=[Mapping Off] Exit (Process Close)

ROMFilter=*.cue

PlaySelectionMusic=True

Website=http://www7a.biglobe.ne.jp/~phantasy/ssf/index.html

StartPageLogo=Sega Saturn

CustomArtPath2=F:\Emulators\SSF\Artwork\Advert

Debug=False

ControlPanelPath=F:\Images\Controls\Emulators\Saturn.png

CDCheck=False

RomPath=F:\Emulators\SSF\Roms

DontShowInfo=False

Version=Ver0.12 alpha

ReplaceDash=False

GameExtenderCustomArtPath=F:\Images\Emus\SAT.png

RandomMostPlayed=True

GamesIn7Zips=False

Category=Console

ShowDesktop=True

CustomBackground=Back-Sega_Saturn.png

UseDbName=False

DATABASE=[Console] Sega Saturn

ShowMostPlayed=True

AlsoLaunch=

MusicPath=

TVAdPath=

VideoSnapPath=

lastgame=

I can't speak to "certain types not working" because all mine are BIN/CUE and I know that works... I don't need to mount for any other emulator (unless I finally decide to get Magic Engine running).

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0