tom

[RESOLVED] extender: can't see other computer screen on different computer.

21 posts in this topic

i am needing help with this program...

i am using a wireless dsl router and have two different computers on it. they are cabled to the router not wireless...

computer that has gameex on it..

(game extender server settings)

enable game extender =yes

ip address =127.0.0.1

port 8383

custom image= no

not found snap= i left it empty

(game extender viewer settings)

server/domain/ip = 127.0.0.1

port= 8383

display on secondary= yes

refresh rate (secs)= 7

run windowed= yes

when i type in 127.0.0.1:8383 on the browser on the same computer as gameex is installed

i can see it working on the same screen so it is working, it's a little box..running under gameex..

and on my other computer i put in the address 127.0.0.1:8383 in my web browser.. and it dont see the screen..

is this possible to do? through a router or do they have to be cabled together and by pass the router?

or do you have to have to video cards?

i read on a thread here to make sure you see the extender running under gameex and it does..

i have been all over the web trying to read and look for info and videos of someone setting this up but not to much out there..just youtube vids of it working but not how to set it up correctly..

got everything other than this working great, just wanted to get this going as it looks great..

want to put a second monitor on my cab..but wanted to check it out first on a second computer if it's possible..

before the major cut job on my cab..

Thank in Advance..

Tom Nichols..

Share this post


Link to post
Share on other sites

Well let me preface this by saying that I don’t use Game Extender, so to anyone else who sees this, please feel free to deliver a verbal smackdown if this information is wrong! :blink:

Having said that, the way you have your IP addresses set up looks a bit wonky. Both the server machine and the client machine are pointing at themselves. 127.0.0.1 is the home address (or loopback address if you’re feeling technical) on any networked computer. From your computers point of view that address always points back at itself, no exceptions.

So while it seems fine that the server machine is pointing at itself (again I may be wrong there), that client machine should probably be pointing at the LAN address of your server. Going out on a limb, but it will probably be something like 198.168.X.XXX (depending on the manufacturer of your router).

To be extra safe you’ll probably also want to setup your server with a static LAN address, but if this is starting to sound Greek to you I’ll stop there, and we’ll take a step by step approach (hopefully with someone that actually uses Game Extender). :P

Share this post


Link to post
Share on other sites

Hi Tom.

127.0.0.1 is the intern IP from your Pc. You can't used this IP for sharing to other PC's.

Go to the Setup wizard and then to the Extender options. Change the IP to your internet Network like 192.168.1.xxx

Then you can share the extender screen to other pc's in the same network

greetings from germany

René

Share this post


Link to post
Share on other sites

still lost here. this is what i got...

my GAMEEX computer has the ip address of =192.168.0.1

subnet mask =254.254.254.0

default gate way = 192.168.254.254

my other computer has the ip address of =192.168.254.6

default gate way =192.168.254.254

what do i put in the gamextender server ip address ? when i click on the box only two numbers show up..127.0.0.1

and the ip address of the computer now =192.168.0.1...

and what number goes in the gamextender viewer settings...

server/ domain/ip =

port=

display on second screen =

refresh rate =

run windowed =

if you give me the right information then i will asume it is in my router settings that stop it from working...

many thanks im new to this extender stuff but not gameex..

Tom Nichols

Share this post


Link to post
Share on other sites

your PCs are not in the same network! give the gameex pc a ip like 192.168.254.5.. go to the network settings from windows and change the ip manually..

then go to the extender option and change the ip to 192.168.254.5

at your other pc open the browser and open the extender website with http://192.168.254.5:8383 when gameex is started

the extender viewer is only for a 2nd monitor on the pc

Share this post


Link to post
Share on other sites

Mine is like this:

Cab IP is 192.168.1.10, Extender port is 6969

On the PC using the same intranet you type the net adapter adding and the port:

HTTP://192.168.1.10:6969

If your PC can see your cab on the network you'll see the Extender screen.

Make sure you have that port forwarded so your firewall isn't blocking you out.

Share this post


Link to post
Share on other sites

Both of my pc can connect to the internet.. through my router... So aren't they on the same network? also my ip address changes every time i restart my computer

Share this post


Link to post
Share on other sites

You have to have a static IP assigned. By default, 99% of home router solutions default to Dynamic (changing) addressing with an IP range. Some of the newer routers allow for a static assignment withing the DHCP range of IP addresses which is necessary for most wireless appliances (Printers, DVRs, etc.).

You will need to assign your PCs a static IP in the DHCP range. Also, you may want to reverify your PCs IP address. 192.168.0.1 is a router default- not a pc IP address! ;)

Share this post


Link to post
Share on other sites

ok. not sure how i did it! gonna look at the ip address but got it going thanks to you guys again..but it seems i have to put in the new ip address on the remote computer every time i restart my gameex computer as the ip address changes every time..on that computer...

:lol: helllz yeahhhh...

Share this post


Link to post
Share on other sites

draco..

how do i make it so my ip address does not change.. assign your PCs a static IP in the DHCP range..

Share this post


Link to post
Share on other sites

That my friend is going to depend on the make of your router. Let’s have a look at some networking concepts in a nutshell.

By default most routers are configured to assign LAN addresses to client machines dynamically via DHCP. That means if you reboot your computer it’s entirely likely that you won’t have the same IP address from one bootup to the next (assuming you haven’t manually altered your computer IP settings).

It sounds like you’ve taken the next step, in that you’ve manually configured your machines IP address. That’s good; that means that every time you boot up that machine it will try to get that IP address and 9 times out of 10 it probably will . . . but there’s a (small) catch.

Remember how your router goes around dynamically assigning IP addresses to machines on your network? What happens if the machine that you’ve manually configured an IP for, isn’t on the LAN at the time your router is happily handing out IP addresses? Well, what happens is your router doesn’t care what IP address your machines have reserved for themselves. If that machine isn’t on the network when the router is handing out addresses, the router will happily give the address to someone else. This can potentially lead to network collisions when your other machine gets on the network and expects that IP address to be available (slow connections, dropped connections, no connection).

So . . . the answer is that you need to tell your router about a range of addresses to reserve from DHCP (dynamic IP assignment). On my router this is called DHCP Reservation. You simply set a range of addresses in your router config, and the router will never dynamically assign addresses in that range. This means that the machines you manually configure will be guaranteed to get the IP address they are expecting (so long as they are in that range). The only trouble is, not all routers have this feature, so your mileage may vary, natch.

Share this post


Link to post
Share on other sites

adultry.

thanks for the info.. like i said got it going..whooo hoooo.. but need to static ip..

if it works now ...i.e. see the other screen on different computer... it means port forward is working? yes or no ?

i just need to make the router no change to different ip address..yes or no ?

Share this post


Link to post
Share on other sites

If your router is capable of that, I would recommend doing so. Have a look at my post previous to this one.

Share this post


Link to post
Share on other sites

ok guys one more little problem im sure you know this..

got it to static ip.. they stay the same now. no switching of the address..

so now when i get the second screen to load on other computer.. and click the mouse i on the screen to enable the remote program running... i see the buttons .. i.e. forward back ect.. but the screen keeps flashing wont stay ..likes it's trying to refresh it ....

Oh and thanx adultry for that program it worked great no problem... :)

Share this post


Link to post
Share on other sites

My router is a Linksys and there is a button to click called Static IP Assign. When I click that, it requires that I input the MAC address of the Network Interface Card (or NIC) and the IP address within the DHCP range I wish to assign. After saving these changes, no matter how many times I reboot, so long as the MAC of the device matches what is in that table, the device will get that IP address. Otherwise, other devices connected to the network through that router will be assigned IP addresses as available within the range. Kinda like a fancy restaurant, only the devices can't bribe the maitre d' to seat them at the table permanently reserved regardless of if the guest shows up or not.

Share this post


Link to post
Share on other sites

draco,

any sugestions oh why the screen flashes now that i got it all working..on the second computer..i put up another question...just before your answer...to your last post..

Share this post


Link to post
Share on other sites

Not sure what is going on with that. There will be updates to the screen periodically but not sure what is causing the flashing you are describing. Maybe a little more information about that machine and display are in order.

Share this post


Link to post
Share on other sites

it all works fine until i click on the screen to try and remote it...funny thing.. im playing around on it to see different settings .if anyone has a suggestion i'll take it.. LOL

Share this post


Link to post
Share on other sites

AAAAhhhhhhaaaa,,

it seems you can't use google chrome whith this as it makes it flash.. i tryed ie 8 and it works fine so i guess this is a closed problem..

thanks to all for the input and help i hope to do the same for others as the have for me..don't know how to post this as resolved

but it is.....

Share this post


Link to post
Share on other sites

I will mark it resolved for you and gald you got it worked out! Welcome to the forums!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.